Cannot install "snapd": cannot install snapd snap on a model without a base snap yet


#1

Snapd is supposed to be pre-installed on Ubuntu 18.04, however when I tried to install a snap of LibreOffice 6.2.2.2 to try and fix problems with my current LibreOffice crashing all the time.
This error popped up:
Unable to install snapd:
cannot install “snapd”: cannot install snapd snap on a model without a base snap yet.
Have searched and seem to be the first reporter.

How do I trouble shoot this?
Where do I find this “base snap?”

System info:
About%20luigiwriter%20computer%20HP%20Envy%2014%202019-04-16%2004


#2

Can you provide the output of the following commands:

snap list
snap changes
snap version

#3

Was just getting eyestrain reading the output of
snap find snapd
so will be glad to.
Can I add multiple attachments, or do I need to copy and paste?
Which would you prefer?


#4
luigiwriter@luigi_Envy14:~$ snap list
Name                  Version                    Rev   Tracking  Publisher        Notes
chromium-ffmpeg       0.1                        13    stable    canonical✓       -
core                  16-2.38                    6673  stable    canonical✓       core
core18                20190409                   941   stable    canonical✓       base
crrcsim-simulator     0.9.13                     1     stable    stanmichals      -
dawnlightsearch       0.1.2.2                    53    beta      chg-hou          -
gnome-3-26-1604       3.26.0.20190228            82    stable/…  canonical✓       -
gnome-3-28-1804       3.28.0-9-gce87599.ce87599  23    stable    canonical✓       -
gnome-calculator      3.32.1                     406   stable/…  canonical✓       -
gnome-characters      v3.32.1+git1.2050bba       254   stable/…  canonical✓       -
gnome-logs            3.32.0-4-ge8f3f37ca8       61    stable/…  canonical✓       -
gnome-system-monitor  3.32.1                     77    stable/…  canonical✓       -
gtk-common-themes     0.1-16-g2287c87            1198  stable/…  canonical✓       -
hatari-emulator       2.2.1                      53    stable    jz               -
kdictionary           1                          2     stable    keshavnrj        -
opera                 60.0.3255.27               32    stable    opera-software✓  -
tesseract             4.1.0-rc1+git263.b1078dd   1453  edge      elopio           -

luigiwriter@luigi_Envy14:~$ snap changes
error: no changes found

luigiwriter@luigi_Envy14:~$ snap version
snap    2.38
snapd   2.38
series  16
ubuntu  18.04
kernel  4.18.0-17-generic

#5
core 16-2.38 6673 stable canonical✓ core
core18 20190409 941 stable canonical✓ base

There is a base snap present and check marked.
puzzling

is there a danger if I try installing snap again using

$ sudo apt update
$ sudo apt install snapd

Don’t want to screw it up worse.
will

sudo apt purge snapd

first be prudent?

Will wait for your analysis of the printouts first. before doing anything else.


#6

Don’t purge your snapd, that will remove all installed snaps as well as their data.

Please hold off until we can think about the situation tomorrow.

EDIT: CC @mvo


#7

Thanks, will wait. brain dead for tax purposes anyway.


#8

What happens when you do snap install libreoffice?


#9

I assume you mean through the Terminal.
Since the version of LibreOffice was not installed from the Ubuntu Software Store I was waiting for instructions from zyga before trying to do anything in that direction. Turns out - see my general reply


#10

Out of desperation, after LibreOffice 6.1 crashed again [and again …] I decided to remove it.
I discovered it now showed up in the Ubuntu Software Store,
so I un-installed LibreOffice 6.1 from there.
I saw that LibreOffice 6.2.2 was now available in the Software Store and as a snap updated on:
04/17/2019 which is about an hour from now according to my clock.
Decided to give it a try expecting the same error message.
The snap installed with no problem and to my relief the LibreOffice seems to be running smoothly.
Since the only difference was un-installing a non snap version of LibreOffice first,
I can only suspect something in that installation was blocking Snapd’s access to Snap Base.
Why and how is beyond me.

Thank you for being here. At least I was not facing this conundrum alone.
Wish I had another computer to try to replicate this on.
Thanks again