[solved] Cannot install snapd snap on a model without a base snap yet


I am experiencing same as @LuigiWriter described in [this thread] (Cannot install "snapd": cannot install snapd snap on a model without a base snap yet).

ychaouche#ychaouche-PC 18:11:27 ~/CalibreLibrary $ snap install snapd
error: cannot install "snapd": cannot install snapd snap on a model without a base snap yet
ychaouche#ychaouche-PC 18:11:32 ~/CalibreLibrary $

snap list

ychaouche#ychaouche-PC 18:17:10 ~/CalibreLibrary $ snap list
Name             Version                     Rev   Tracking  Publisher     Notes
bare             1.0                         5     stable    canonicalâś“    base
certbot                                      2133  stable    certbot-effâś“  broken
chromium-ffmpeg  0.1                         28    stable    canonicalâś“    -
core18           20220428                    2409  stable    canonicalâś“    base
core20           20220527                    1518  stable    canonicalâś“    base
gnome-3-28-1804  3.28.0-19-g98f9e67.98f9e67  161   stable    canonicalâś“    -
riseup-vpn       0.21.11-14-gb798364         179   beta      leapsnaps     classic
zerotier         1.10.0                      180   stable    zerotier      -
ychaouche#ychaouche-PC 18:17:12 ~/CalibreLibrary $

snap version

ychaouche#ychaouche-PC 18:20:40 ~/CalibreLibrary $ snap version
snap    2.38~14.04
snapd   2.38~14.04
series  16
ubuntu  14.04
kernel  4.4.0-98-generic
ychaouche#ychaouche-PC 18:25:15 ~/CalibreLibrary $ 

snap changes

ychaouche#ychaouche-PC 18:25:15 ~/CalibreLibrary $ snap changes
ID   Status  Spawn               Ready               Summary
19   Done    today at 16:36 CET  today at 16:36 CET  Remove "riseup-vpn" snap
20   Done    today at 16:37 CET  today at 16:37 CET  Install "riseup-vpn" snap
21   Done    today at 16:48 CET  today at 16:48 CET  Refresh "riseup-vpn" snap from "beta" channel
22   Error   today at 17:50 CET  today at 18:03 CET  Install "opera" snap
23   Error   today at 18:09 CET  today at 18:09 CET  Install "opera" snap

Any help appreciated. The goal of installing snapd from snap (and not the package manager) is to install opera (which decided snapd wasn’t recent enough, and for a good reason I suppose).

Here’s my attempt at installing opera (it sucks the download snap isn’t cached somewhere, an immediate reinstall would re-download the whole package)

ychaouche#ychaouche-PC 17:30:33 ~/CalibreLibrary $ snap install opera
error: cannot perform the following tasks:
- Mount snap "opera" (181) (snap "opera" assumes unsupported features: snapd2.43 (try to update snapd and refresh the core snap))
- Download snap "gtk-common-themes" (1534) from channel "stable" (unexpected EOF)
ychaouche#ychaouche-PC 18:03:56 ~/CalibreLibrary $

Try installing the core snap first. This should make a more recent version of snapd available in the system.

Thanks for the reply @mborzecki; I have core18 and core20 installed as per the snap list listing. According to snap blame, this is all Mark Shuttleworth’s fault. You only come at the 18th position :slight_smile:

I meant to try installing the core (not 18 or 20) snap first, i.e. snap install core.

1 Like

Sorry wasn’t aware of the difference. Installing.

Problem solved! Thanks a lot @mborzecki.

1 Like