Trouble with Snap ScummVM on Raspian

I am running Raspian 10 (buster) on a Pi4 and I’ve tried the following through the terminal:

$ sudo apt update
$ sudo apt install snapd

Then reboot and:

$ sudo snap install scummvm

I receive the following error:

2020-08-04T19:25:19+01:00 INFO snap "scummvm" has bad plugs or slots:
audio-playback (unknown interface "audio-playback")
scummvm 2.1.2 from Snapcrafters installed

When I try to run ScummVM from the command line after a reboot, I get many errors. Any idea what I can do?

Here is the errors on running ScummVM if that helps at all:

You need to use a newer snapd, and the scummvm snap should probably protect against this by using assumes: [snapd2.43] or whatever version audio-playback was added to

Thanks for the response!

I’m really sorry to ask these probably obvious questions; but how do I go about getting a newer snapd…? I’ve tried “sudo apt full-upgrade” but that didn’t change anything with snapd.

Is there a way I can amend the snap in regard to this audio-playback issue, or is that something that I need to put in some kind of change request?

You can get a newer snapd using snap, sudo snap install snapd should install the latest stable version.

This is what I receive when I try to do that - I include the initial lines just to show snapd is installed…

pi@raspberrypi:~ $ sudo apt install snapd
Reading package lists... Done
Building dependency tree       
Reading state information... Done
snapd is already the newest version (2.37.4-1+rpi1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

pi@raspberrypi:~ $ sudo snap install snapd
error: cannot install "snapd": cannot install snapd snap on a model without a
       base snap yet

I see this error message was also raised in: Cannot install "snapd": cannot install snapd snap on a model without a base snap yet

In case any of the detail asked for on that issue is needed here, I’ll include it.

pi@raspberrypi:~ $ snap list
Name Version Rev Tracking Publisher Notes
core18 20200707 1882 stable canonical✓ base
gnome-3-28-1804 3.28.0-17-gde3d74c.de3d74c 129 stable canonical✓ -
gtk-common-themes 0.1-36-gc75f853 1506 stable canonical✓ -
scummvm 2.1.2 3996 stable snapcrafters -

pi@raspberrypi:~ $ snap changes
ID Status Spawn Ready Summary
1 Done yesterday at 23:05 BST yesterday at 23:05 BST Initialize system state
2 Done today at 07:49 BST today at 07:56 BST Install “scummvm” snap
3 Done today at 07:49 BST today at 07:49 BST Initialize device
4 Done today at 07:56 BST today at 07:56 BST Running service command for snap “scummvm”

pi@raspberrypi:~ $ snap version
snap 2.37.4-1+rpi1
snapd 2.37.4-1+rpi1
series 16
raspbian 10
kernel 5.4.51-v7l+

Try sudo snap install core in that case

1 Like

Okay, that updated the version but now I have a new problem. This is after the ScummVM download bar had finished getting to 100%.

pi@raspberrypi:~ $ sudo snap install scummvm

Warning: /snap/bin was not found in your $PATH. If you’ve not restarted your session since you installed snapd, try doing that. Please see for more details.

I had restarted before I tried to install ScummVM.

Here is my current version:

pi@raspberrypi:~ $ snap version
snap 2.45.2
snapd 2.45.2
series 16
raspbian 10
kernel 5.4.51-v7l+

PRETTY_NAME=“Raspbian GNU/Linux 10 (buster)”

NAME=“Raspbian GNU/Linux”


VERSION=“10 (buster)”







My shell is “/bin/bash”

I wiped my Pi and started again in case this was to do with something I’d done previously, but it doesn’t seem to be.

well, thats just a warning (and easily solved by adding a symlink as described in the linked forum post) … do you mean you do not get your prompt back when the install is done ? is there anything interesting in your systemd journal ?

I couldn’t find any reference to “symlink” in the attached forum post, I have looked through it. If that was a warning and the install worked I really wouldn’t mind. ScummVM certainly doesn’t work after the install, many errors.

Would the entries from terminal when I try to run ScummVM be of use? I’ll find the systemd journal when I am by my Pi again.

I booted Raspbian (well, the current Raspberry Pi OS in fact) in a Pi4 and was able to reproduce the issues you described (had to install the core snap before installing snapd, and got the message about /snap/bin not being on $PATH despite the fact that it’s there). After that, applications installed as snap packages seem to work correcty. I didn’t test scummvm specifically because my pi is headless, but I would expect it to work on a system capable of graphic output.

Update: Could you post the errors you get when you try to execute scummvm to help us diagnose what could be happening?


The message about /snap/bin not being in $PATH is in fact caused by the directory not being in the secure path defined in /etc/sudoers. Perhaps this message could be clearer about what the issue really is.

Thank you so much for looking into this, I appreciate it! :slight_smile:

Here is the error log:

There’s an investigation about the preload error here:

It seems to be safe to just remove (or comment out) that entry from /etc/ to stop all the noise (but you may want leave it there to have the performance gains in the rest of the system), however the real problem seems to be related to ALSA. I checked in my system and all sound-related interfaces seem to be properly connected (audio-playback, alsa, pulseaudio) but you can check locally with snap connections scummvm.

Do you have pulseaudio installed?

I haven’t installed pulseaudio additionally to the image, but I downloaded the image described as "
Raspberry Pi OS (32-bit) with desktop and recommended software" from here:

So I thought pulseaudio may already be installed, but actually if I look to install it, it doesn’t appear to be there already:

pi@raspberrypi:~ $ sudo apt install pulseaudio
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following package was automatically installed and is no longer required:
Use ‘sudo apt autoremove’ to remove it.
The following additional packages will be installed:
libasound2-plugins libpulsedsp pulseaudio-utils rtkit
Suggested packages:
pavumeter pavucontrol paman paprefs
The following NEW packages will be installed:
libasound2-plugins libpulsedsp pulseaudio pulseaudio-utils rtkit
0 upgraded, 5 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,253 kB of archives.
After this operation, 6,564 kB of additional disk space will be used.
Do you want to continue? [Y/n] n

Should I install it?

Connections are here:

pi@raspberrypi:~ $ snap connections scummvm
Interface Plug Slot Notes
alsa scummvm:alsa :alsa -
audio-playback scummvm:audio-playback :audio-playback -
content[gnome-3-28-1804] scummvm:gnome-3-28-1804 gnome-3-28-1804:gnome-3-28-1804 -
content[gtk-3-themes] scummvm:gtk-3-themes gtk-common-themes:gtk-3-themes -
content[icon-themes] scummvm:icon-themes gtk-common-themes:icon-themes -
content[sound-themes] scummvm:sound-themes gtk-common-themes:sound-themes -
desktop scummvm:desktop :desktop -
desktop-legacy scummvm:desktop-legacy :desktop-legacy -
gsettings scummvm:gsettings :gsettings -
home scummvm:home :home -
joystick scummvm:joystick :joystick -
mount-observe scummvm:mount-observe - -
network scummvm:network :network -
network-bind scummvm:network-bind :network-bind -
opengl scummvm:opengl :opengl -
pulseaudio scummvm:pulseaudio :pulseaudio -
removable-media scummvm:removable-media - -
unity7 scummvm:unity7 :unity7 -
wayland scummvm:wayland :wayland -
x11 scummvm:x11 :x11 -


Should I install it?

Yes, let’s try to install it. You may need to start it with pulseaudio -D if it’s not running, then execute scummvm. (You can force scummvm to use the pulseaudio driver running SDL_AUDIODRIVER=pulse scummvm to be sure it’s trying to use the right driver.)

That has worked - it loads! But (I wish there was no but) the sound doesn’t work. It just makes farty noises essentially, I’ve tried a few games. This time I installed pulseaudio first, and I also installed ScummVM through the Snap-Store, not sure if that made a difference though.

Edit: It was definitely Pulse Audio that makes the difference, if I launch it ScummVM with Alsa then I get the same old segmentation error as I used to get. I tried “artsc” also as I read that was a possible option.

I guess this may be getting into more of a ScummVM issue than the Snap. I can revert back to the 2.0.0 release that gets installed by the standard terminal install, the only one of my games I can’t get to work is Blade Runner, which does work in the Snap version (although the sound doesn’t work).

Reading the ScummVM ticket I originally raised for this, the ScummVM dev on there had the same issue:

I did try the snap package, but it was buggy on my RPi at the time. The more prominent issue that I recall was with pulseaudio conflicts which resulted in noisy audio. I also do recall several warnings being printed out on the console while launching ScummVM but I don’t think I have kept a log of those. These issue may have been resolved in the latest Raspbian and snap package for all I know.