Call for testing: foobar2000


#1

Released my wine i386 based snap to stable channel.

snap repo

Tested this snap working fine under updated as of 29/01/2018 below distributions:

ubuntu 16.04.3 amd64 & i386
ubuntu unity remix 18.04 amd64
kde neon user edition amd64
manjaro xfce 17.1.2 stable amd64

Install Instructions

Stable

sudo snap install foobar2000

Beta

sudo snap install foobar2000 --beta

Mandatory Plug

sudo snap connect foobar2000:process-control

Optional Plugs

sudo snap connect foobar2000:removable-media
sudo snap connect foobar2000:hardware-observe
sudo snap connect foobar2000:cups-control

Screenshot

repo wiki for more info

Feedback is welcome.


Foobar2000 is not running
Request to auto-connect interface "process-control" for foobar2000
#2

A WINE snap? Wow - super work!

It almost works for me. I can launch the app and select a file, but I get an error if I try to play it:

Any tips on how I can fix that?

Ubuntu 16.04, Unity, HDMI audio via proprietary nvidia drivers.


#3

I’ve also been working on wine, but have been struggling with audio. Of the interfaces above I found that the only one required was the process-control. Although the hardware-observe being absent in my builds is possibly why I’m having trouble with audio. I’ve been building WINE from source, though, to get the latest version.


#4

the hadware-observe helps with some denials (that seem to be harmless), but wont have any affect on audio … audio is the one thing i havent gotten working since i started playing with wine, i was pondering to take a look at your alsa-lib part from the other thread to include alsa in the snap though …


#5

I deleted the $HOME/snap/foobar2000 directory and launched again. It seems to work perfectly now. Initially I launched it before making the interface connections which seemed to break it. I wonder if there is a way to prevent that happening?

Excellent work. I look forward to stealing your ideas :slight_smile:


#6

You could be missing this $SNAP/usr/lib/$ARCH/pulseaudio on $LD_LIBRARY_PATH also check wine log on terminal when running winecfg then going to audio tab will trigger it to load audio libs if these are missing from snap then log on terminal will show errors missing libs then add em on staging.


#7

Yeah wrapper script had some issues linking files on revision upgrades it was breaking the app its all fixed now.

You can update snap with sudo snap refresh foobar2000

Interface connections are only needed to connect if you are installing snap for first time then these must be connected before first run and if you remove snap then install again, it will need these to be connected again.

Interfaces are needed for any wine based app in order to work.

Thanks


#8

that should be handled by the desktop-helpers script desktop-launch.


#9

While this is true, adding megabytes of desktop dependencies to your snap just to get this path set is probably a bit heavyweight :slight_smile:

also … looking at the wrapper script it seems to set the path correctly …


#10

Thanks for your work. I hope that you continue support this app :relieved:


#11

There is any possibility to make online addons work (like Lyric Show Panel)?


#12

It should be fixed now on stable and beta branches.

cheers.
TR


#13

Hey, really liking this so far - glad I could keep the best media player after making the switch away from Windows thanks to this :slight_smile:

Only issue I have so far is that keyboard media buttons don’t get passed through to foobar, making the play/pause/stop forward/next unresponsive. Is there a plug to allow this? (All 4 recommended+required plugs are connected).

Thanks!


#14

Media keys do work fine here when player shown on screen however if player is minimize they don’t respond, this is also same with non snap WINE so this might be a WINE issue. It would be better to report this issue on winehq.


#15

They don’t work for me even when the window is in focus and selected, even testing an install in devmode :confused:

Checking the winehq page, it looks like there was an issue for it here (#16367). Reading through their discussion, I tested that the media buttons do work IF I have the window in focus and press Ctrl+[media]. It was supposedly fixed in wine version 1.7.47 - what version is the foobar snap using? If it’s earlier could you test it?

If not it may have been explicitly broken by the related issue (#1348), where they implemented a hack so it would ignore Ctrl+# commands without focus (I guess apps like photoshop were responding to Ctrl+Z and the like when they didn’t have focus).

I don’t know how to check the version the snap is using, but if it’s up to date I’ll update the ticket on the issue.


#16

Also, jank way to fix this: foobar2000 does support command line arguments. For now at least, (in Ubuntu 18.04) I just set up four custom keyboard shortcuts (and disabled the default play/pause/stop/next/prev buttons) and added:

Play/Pause -> command: foobar2000 -playpause
Next       -> command: foobar2000 -next
Previous   -> command: foobar2000 -prev
Stop       -> command: foobar2000 -stop

This of course works everywhere and regardless of focus, but the side effect is that if you press one of these while foobar is closed, it will open foobar - and this will override any other media player actions. For my case it’s fine though since it’ll (continue to be) my dedicated media player.

Secondary minor issue though: it doesn’t support WMA files out of the box :wink:


#17

I’ve fixed the WMA and WMV playback support should work now and make sure you remove .wine folder from ~/snap/foobar2000/common before launching player with new changes & snap is using the wine-stable 3.0.2.

Earlier I said media keys are working when player is focused those were dedicated multimedia keys on keyboard not shortcut keys.


#18

Ah - ok, so the default shortcuts settings must have been intercepting the media keys on the OS layer, unless paired with something else making it unassigned. Disabling all the relevant shortcuts makes the keys work like you said: by themselves, if foobar2k is in focus. Thanks for the version info, I’ll see about updating the ticket on winehq.

Also thanks for the update for WMA - that was fast, and it works perfectly!