Using chromium-ffmpeg in third-party browser snaps

Based on the replies to other threads here it looks to me like xshi (and gmiazga too) might work for them. :wink:

1 Like

Thanks for the confirmation, released to stable.

New slot added: chromium-ffmpeg-114023 .

2 Likes

Hi there,

First of all, thank you so much for maintaining this snap! May I ask for a new slot, please? The Opera browser now is based on Chromium version 124 so the chromium-ffmpeg-114023 version doesn’t work anymore.

Thanks again for your hard work!

Cheers.

Hi Rigo, sorry for the delay tackling this. The Launchpad builder is hitting a strange no space left on device problem but I just wanted to let you know this wasn’t missed.

1 Like

Hi again, so the only way I found to circumvent the issue was to delete all other slots — I think that is no problem as current Opera won’t work with the old slots anyway. Can you please try the chromium-ffmpeg snap from the candidate channel and report back?

1 Like

HI @nteodosio :slight_smile: ,

I’m happy to report that I just tested it and it’s working great!

Thanks again for your work!

Cheers, Rigo

1 Like

I’d assume the Opera dev version will switch to Chromium version 126 in the near future so perhaps time to add chromium-ffmpeg-116067 and be one step ahead, so when Opera arrives everything works out the box?

2 Likes

Hi @nteodosio :slight_smile: ,

Sorry to bother you again :anguished:

But as it always happens, Opera changed versions again and the Opera Beta version (Which I use) now picked up Chromium 125 for its codebase.

May I ask for another slot, please? I really appreciated your work!

Thanks in advance for your help on this.

Cheers, Rigo.

Hey @rigo, that is not bothering of course, feel free to ask every time you want. (:

Can’t you connect chromium-ffmpeg-115541 for it? That is based on Chromium 125.

Hi, Vivaldi browser (who I work for) is looking at adding our product to the snap store. Like Opera, we would use “chromium-ffmpeg”. However unlike Opera we support three architectures amd64, arm64 and armhf.

Since only amd64 binaries are provided for “chromium-ffmpeg”, this prevents install of a local, test Vivaldi snap on the arm based architectures.

Would you be open to supporting arm64 and armhf for “chromium-ffmpeg” in the future?

EDIT 1: I see the error mentions i386 is available, which seems weird given Opera (the only packaging using this of currently AFAICT) does not not have a i386 package.

EDIT 2: Ok, I looked at the meta data on that package and see that the i386 package is wildy out of date having been last updated in May 2023. So I assume this arch is effectively dead as far as “chromium-ffmpeg” goes anyway.

Would you be open to supporting arm64 and armhf for “chromium-ffmpeg” in the future?

Yes, I will let you know when they are available.

the i386 package is wildy out of date having been last updated in May 2023. So I assume this arch is effectively dead as far as “chromium-ffmpeg” goes anyway.

Correct.

1 Like

Heads up, it will work anyway. I did some pretty extensive testing with the 125 libffmpeg (a.k.a. 115541) in Vivaldi snapshot (which is based on 126). It works flawlessly AFAICT.

Good news, @ruario, it’s built on ARM but that’s is 115541(from 125) slot, is that of use for a test with Vivaldi?

I’ll be building with the remaining slots anyway and let you know when it’s all ready.

1 Like

115541 is fine… perfect in fact! Thank you! We will likely release Vivaldi 6.8 before the week is out. That will be Chromium 126 based and it should work with 115541 without issue AFAICT.

I see from the link you gave that is arm64, are you able to offer armhf as well?

P.S. To be clear we do not need any versions older than 115541

Nice, do you have an Aarch64 at hand to test it? If yes, please install from candidate channel: snap install --candidate chromium-ffmpeg and then connect it to Vivaldi.

Armhf will come too, it’s just that ARM builds often hiccup on connectivity and I have to keep retrying them until they go through.

Hi @nteodosio,

Thanks for your reply and sorry for the late reply. I tried it but I ran into another problem. The command line displays this error message:

opera-beta: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.38' not found (required by /usr/lib/x86_64-linux-gnu/opera-beta/lib_extra/libffmpeg.so)

Turns out that Linux Mint uses Glibc 2.35 :frowning: And from what I’ve read about there’s no 2.38 updates available, and messing with Glibc would be unwise. Is there any chance you may compile it using a lower Glibc version? I’d understand if you can’t but I’d also really appreciate if you do :slight_smile:

Hope you have a great weekend ahead!

Cheers, Rigo

Hi @rigo, what exactly is the command you use to launch opera-beta? Sorry if this sounds pedantic, but as some people use the /snap/{snap-name}/current/ path which causes the application to be launched unsandboxed, thus causing such sort of issues.

Can you also add snap list to your response?

Armhf is also available on the candidate channel now.

@rigo, I think I figured the issue, the ffmpeg snap was built with core24 as base, whereas Opera uses core22. I published on the --beta channel the ffmpeg snap with core22 base. That’s what will be eventually released to stable.