Support for Raspberry Pi 3 Model B+


#81

Yep, different kernel … (even the MAC thing is fine in the 4.15 kernel of core 18 … for the 4.4 kernel in core 16 every feature is a backport job though)


#82

@vpetersson understood that you need the LED bug fixed before you can put this into production.

Can you confirm that this LED problem only affects the 3B+ and not the other models that are currently supported by UC16? (I have also asked our certification team to confirm this.)

If this is a regression on pre-3B+ models, then it should be a blocker for updating the pi2-kernel snap in the stable channel.

If this remaining bug only affects the 3B+, then I think we should not block the release of the current snap, or block the release of an updated UC16 image with 3B+ support, since the bug does not block delivery of a fixed kernel snap to affected systems after installation.

Either way, as soon as @ppisati has a fix for the LED bug on the xenial kernel, that will make its way into the pipline for the next kernel snap update.


#83

the pre-b+ models are all fine, the b+ uses a completely new NIC (gigE attached to USB 2.x) which is sadly not fully supported in 4.4 and causes all the backporting.


#84

I haven’t tried the new Candidate image on the regular B myself, but as @ogra points out, it most likely works. Just to be safe, can you confirm @renat2017?


#85

Can you confirm that this LED problem only affects the 3B+ and not the other models that are currently supported by UC16? (I have also asked our certification team to confirm this.)

@slangasek, @vpetersson, I confirm that it does not affect regular raspi 3.


#86

Same here, lights are working fine on my pi3B v1.2, just not on my pi3B+


#87

Is 8th November still the estimated release date or did it get pushed back?


#88

We are not quite ready yet. I don’t have an updated date just yet, of course if you need something from Ubuntu Core 18 specifically please do reach out to me on email and we can discuss it further.


#89

@slangasek said “around” the 8th. Seems it was uploaded on a friday (Oct. 26th) to edge (and to -proposed in the ubuntu archive) so i guess tomorrow the 2 week quarantaine is actually over and it will migrate …

i’ll ping the kernel team again tomorrow just to make sure …


#90

With core from edge on the pi 3b+ I’m not seeing any wifi networks. I’m sat in the London office, so I know there’s a ton nearby.

popey@localhost:~$ snap info core
name:      core
summary:   snapd runtime environment
publisher: Canonical✓
contact:   snaps@canonical.com
license:   unset
description: |
  The core runtime environment for snapd
type:         core
snap-id:      99T7MUlRhtI3U0QFgl5mXXESAiSwt776
tracking:     edge
refresh-date: today at 14:09 UTC
channels:                                                 
  stable:    16-2.35.5               (5744) 77MB -    
  candidate: 16-2.35.5               (5744) 77MB -    
  beta:      16-2.36                 (5796) 78MB -    
  edge:      16-2.36+git1003.fb669c3 (5894) 78MB -    <
installed:   16-2.36+git1003.fb669c3 (5894) 78MB core 
popey@localhost:~$ snap list
Name             Version                  Rev   Tracking  Publisher     Notes
classic          16.04                    42    edge      canonical✓    devmode
core             16-2.36+git1003.fb669c3  5894  edge      canonical✓    core
network-manager  1.2.2-18-dev             321   edge      canonical✓    -
pi2-kernel       4.4.0-1100.108           78    edge      canonical✓    kernel
pi3              16.04-0.6                27    edge      canonical✓    gadget
wormhole         0.10.3                   25    stable    snapcrafters  -
popey@localhost:~$ nmcli radio
WIFI-HW  WIFI     WWAN-HW  WWAN    
enabled  enabled  enabled  enabled 
popey@localhost:~$ nmcli device wifi rescan
popey@localhost:~$ nmcli device wifi list
*  SSID  MODE  CHAN  RATE  SIGNAL  BARS  SECURITY 
popey@localhost:~$ nmcli device wifi connect Canonical password thisisnotthepassword
Error: No network with SSID 'Canonical' found.
popey@localhost:~$ nmcli device status
DEVICE  TYPE      STATE        CONNECTION 
wlan0   wifi      unavailable  --         
eth0    ethernet  unmanaged    --         
lo      loopback  unmanaged    --       

#91

did you try without network-manager installed ?

I have honestly never used NM on core and my b+ definitely finds even the WIFIs across the street from my neighbors when i run sudo console-conf (and we used the b+ WIFI as well during IoT world congress in barcelona last month where the list of WLANs didnt even fit in one terminal page)

the WLAN hardware in the b+ is identical to the one in the normal pi3 so it is surprising that you see issues here, AFAIK there were no kernel changes on the WIFI driver.


#92

I have to use sudo console-conf? Ok. Thanks.

Yes, that worked. Bit strange that I can’t just use the network manager tools to do the same.

Will it remember all networks (like my laptop) or does it only know one wifi at a time? So when I take this home will I have to undo this config and re-set it to home wifi?


#93

i didnt say have to :wink:

but thats what i use usually, sounds like a bug in the edge NM with this particular broadcom driver to me…

i guess for multi-network support you’d have to craft a netplan yaml with multiple entries, conole-conf currently only writes an entry for the current configuration …

for my home-images i recently started using configuration snaps that auto-import a netplan.yaml from USB key like in (see the netplan-import script):

that way i only have to put the right config on an USB key, plug it in and the device will auto-configure itself for the new network.


#94
$ snap info pi2-kernel|grep stable
  stable:       4.4.0-1100.108 (78) 135MB -

The kernel snap just moved to stable, it should now have all known b+ fixes with the exception of the LED fix which is still in the works.

The next stable UC16 image build will include this kernel snap too (i do not know the exact release cadence here, this is in the hands of the foundations team … @slangasek or @sil2100 should be able to give a date though)


#95

Thanks, @ogra! We’ll generate new images asap.


#96

And for completion, here is the bug for the LED issue:

https://bugs.launchpad.net/ubuntu/+source/linux-raspi2/+bug/1802320


#97

An updated image build from the channel is available here: http://cdimage.ubuntu.com/ubuntu-core/16/stable/20181109.4/

This will be released to stable if it passes QA.