Support for Raspberry Pi 3 Model B+


#1

Do we have a timeline for getting Core to work on the Raspberry Pi 3 Model B+?


Classic on Core 18
#2

I intend on buying several in the next couple of months and would love to run Ubuntu Core on them.


#3

Given that the changes in the chipset are pretty small, I would imagine that it’s just a matter sucking in the new firmware blob from upstream. The previous Raspbian will not boot on the B+ either.


#4

There are currently no official plans but the gadget source is built in a way that you should be easily able to switch to a newer tag in snapcraft.yaml to pull in the newer firmware … if someone from the community wants to test and send a PR i’m happy to review and merge it into the pi3 gadget.


#5

I have a B+ sitting at my office. Happy to test an image if someone can build one.


#6

@ondra has one on his desk :slight_smile: Maybe he can help test @ogra


#7

We’re all eagerly awaiting the result, @ondra! :slight_smile:


#8

Any updates on this, guys?


#9

Still no update? :frowning:


GA date for RPi 3B+ Core Image
#10

@vpetersson Sorry for the delay… I’ll ping @ondra elsewhere so he provides an update here. I also don’t have the details on progress, but I expect it to be easier now that we’re about done with 18.04.


#11

This will likely take more time since:

  • Core will need a working u-boot port (to my knowledge not existing yet)
  • Someone (likely the Ubuntu kernel team) will have to backport all kernel patches from recent mainline to the Ubuntu Core 4.4 kernel (this might be non-trivial)

AFAIK @ondra tried to boot his board but is not even able to get to a working u-boot yet.


#12

@ogra Needs a u-boot port in what sense? The u-boot logic is integrated into snapd proper for a long time.


#13

typically u-boot upstream needs code for new boards to support them from the u-boot binary …

i dont see any commits for the b+ yet at

http://git.denx.de/?p=u-boot.git;a=shortlog


#14

I’m a bit confused about that too. AFIK, it’s almost identical to Raspberry Pi 3 Model B from a chipset perspective. I assumed we only needed to suck in a fw blob from the Foundation upstream for this.


#15

AFAIK that is what @ondra tried but he can not get u-boot to start at all which imples there are more bits needed.
(lets wait until he can comment himself so we get first-hand info)

in any case there are a bunch of kernel patches needed even if the bootloader works, not sure if the kernel team picked up the backport to 4.4 yet, perhaps @ppisati knows.


#16

This is the kernel patch set that enables b+ in the latest bionic 4.15 kernel and likely the set that needs backporting to 4.4 to be included in the pi2-kernel snap.

https://lists.ubuntu.com/archives/kernel-team/2018-April/091437.html


#17

hi all
sorry for slow response
Finally got time to thinker with Pi3+
Gadget snap part problem is now resolved and I have basic image booting. This has no pi3+ specifics and I’m now waiting for kernel build to get more hw enabled.
Tasks to still complete: integrate Pi3+ bits into 4.4 kernel
And more work on gadget snap, so we can use same gadget for Pi3 and Pi3+
I will keep reporting here, but expect some early beta image soon
If we


#18

hi
so test image could be find here
http://people.canonical.com/~okubik/ubuntu-core-pi3-20180426-01.img.xz

I will now work with relevant teams to test and merge changes

word of warning, raspberry foundation only supports 4.14 and 4.15 kernel for 3+
While checking their changes, it seems to be mainly centred around bug fixes in ethernet drivers which on it’s own seems to be heavily changed between 4.4 and 4.14

Wifi seems to have trouble to connect to existing network, this seems to be related to
https://bugs.launchpad.net/ubuntu/+source/nplan/+bug/1712224
Kudo to @ogra for pointing out netplan issue!


#19

Oh, it looks like I need a new member of my test farm :slight_smile:


#20

@ondra / @zyga any update on this?