Snapd not updating

Hi,

First time snap user on Centos 7.8. Please forgive any novice-level questions.

I needed snap to install OBS Studio and, for a while, it was working. The auto-refreshes seemed to be running OK and I installed theFreemind mind-mapper software from the Snap store. Freemind still works. OBS Studio crashes with a blank error screen (no message, just an OK button).

Looking at the basic OS and snap information I see:

280 root@white# uname -a
Linux white 3.10.0-1127.18.2.el7.x86_64 #1 SMP Sun Jul 26 15:27:06 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
281 root@white# cat /etc/centos-release
CentOS Linux release 7.8.2003 (Core)
282 root@white# snap list
Name Version Rev Tracking Publisher Notes
core18 20200724 1885 latest/stable canonicalâś“ base
freemind 1.1.0-Beta-2 4 latest/stable jibel -
gtk-common-themes 0.1-36-gc75f853 1506 latest/stable canonicalâś“ -
obs-studio 25.0.8 1124 latest/stable snapcrafters -
snapd 2.45.3.1 8790 latest/stable canonicalâś“ snapd
283 root@white# snap refresh --list
Name Version Rev Publisher Notes
snapd 2.46.1 9279 canonicalâś“ snapd
284 root@white#

As you can see, snapd is several revisions behind the current release and has been for the last few days. I got the following results from snap info:

285 root@white# snap info core
name: core
summary: snapd runtime environment
publisher: Canonicalâś“
store-url: https://snapcraft.io/core
contact: snaps@canonical.com
license: Other Open Source
description: |
The core runtime environment for snapd
type: core
snap-id: 99T7MUlRhtI3U0QFgl5mXXESAiSwt776
channels:
latest/stable: 16-2.46.1 2020-09-16 (9993) 101MB -
latest/candidate: 16-2.46.1 2020-09-08 (9993) 101MB -
latest/beta: 16-2.46.1 2020-09-07 (9993) 101MB -
latest/edge: 16-2.46.1+git2310.81569243 2020-09-16 (10045) 102MB -
286 root@white#

286 root@white# snap info snapd
name: snapd
summary: Background service that manages and maintains installed snaps
publisher: Canonicalâś“
store-url: https://snapcraft.io/snapd
license: GPL-3.0
description: |
Note: you do not need to install snapd manually if you already have snap installed.
… etc … etc …
type: snapd
snap-id: PMrrV4ml8uWuEUDBT8dSGnKUYbevVhc4
tracking: latest/stable
refresh-date: today at 13:26 BST
channels:
latest/stable: 2.46.1 2020-09-16 (9279) 31MB -
latest/candidate: 2.46.1 2020-09-08 (9279) 31MB -
latest/beta: 2.47~pre1+git733.g799ae88 2020-09-21 (9494) 32MB -
latest/edge: 2.47~pre1+git797.g7527dfa 2020-09-22 (9507) 32MB -
installed: 2.45.3.1 (8790) 31MB snapd
287 root@white#

287 root@white# snap info obs-studio
name: obs-studio
summary: OBS Studio for live streaming and screen recording
publisher: Snapcrafters
store-url: https://snapcraft.io/obs-studio
contact: https://github.com/snapcrafters/obs-studio/issues
license: unset
description: |
OBS Studio is software designed for capturing, compositing, encoding, recording, and streaming
video content, efficiently. This is a community-supported modified build of OBS Studio; please
file issues on the Snapcrafters GitHub:
https://github.com/snapcrafters/obs-studio/issues
… etc … etc …
commands:

  • obs-studio
    snap-id: 6uLU2MJmBURfLNz4rmL4WT2CmtVULE2u
    tracking: latest/stable
    refresh-date: 20 days ago, at 05:35 BST
    channels:
    latest/stable: 25.0.8 2020-09-02 (1124) 179MB -
    latest/candidate: ↑
    latest/beta: ↑
    latest/edge: 25.0.8 2020-09-22 (1133) 179MB -
    installed: 25.0.8 (1124) 179MB -
    288 root@white#

According to Why is Canonical "core" snap not being updated?

“When a new core snap is released, it goes through a “progressive release” phase (also known as canarying in other circles) where a certain percentage of folks receive the update. If after a day or two you still have not received the update, please report back and we’ll investigate.”

I guess I have a few questions (sorry):

Does the same “progressive release” phase apply to snapd itself?
Do you need any further information to assist in this query?
Is this a snapd problem or an obs-studio problem?

I’d like to get snapd updated to enable OBS Studio updates for a live-streaming project, which is coming soon.

Please let me know if there’s any more information you require and I’ll respond as soon as I can.

Regards,
Colin Brett

Yes

I checked and snapd should no longer be phasing the update, so your system should be getting the update the next time it checks for refreshes.

What is the output of the following:

snap refresh --time

Hello Ian,

As requested:

318 root@white# snap refresh --time
timer: 00:00~24:00/4
last: today at 13:13 BST
next: today at 21:02 BST
319 root@white#

When I tried to refresh snapd from the command line, I get:

308 root@white# snap refresh snapd
error: cannot perform the following tasks:

  • Setup snap “snapd” (9279) security profiles (cannot update mount namespace of snap “obs-studio”: cannot update preserved namespace of snap “obs-studio”: cannot update snap namespace: no such file or directory)
    309 root@white#

Most of the messages are hidden behind the progress bars and disappeared too quickly to write down. So I used script to capture the
output and found an interesting message:

Consider re-refresh of “snapd”

What is a re-refresh, please?

Thanks for your help so far.

Regards,
Colin

Ah, this seems to be your problem, the obs-studio’s snap mount namespace is stuck. Try this:

sudo /usr/lib/snapd/snap-discard-ns obs-studio
snap refresh snapd

This is an internal implementation detail and not relevant to your problem.

1 Like

Hi Ian,

Your solution worked. Snapd has updated and OBS works. For the record, this is what I did:

338 root@white# script
Script started, file is typescript
1 root@white# pwd
/root/PROJECTS/snap
2 root@white# /usr/libexec/snapd/snap-discard-ns obs-studio
3 root@white#
3 root@white# snap refresh snapd
2020-09-22T18:42:21+01:00 INFO Waiting for automatic snapd restart…
2020-09-22T18:42:22+01:00 INFO Waiting for automatic snapd restart…
snapd 2.46.1 from Canonicalâś“ refreshed
4 root@white# exit
Script done, file is typescript
339 root@white#

339 root@white# snap refresh --list
All snaps up to date.
340 root@white#

340 root@white# snap list
Name Version Rev Tracking Publisher Notes
core18 20200724 1885 latest/stable canonicalâś“ base
freemind 1.1.0-Beta-2 4 latest/stable jibel -
gtk-common-themes 0.1-36-gc75f853 1506 latest/stable canonicalâś“ -
obs-studio 25.0.8 1124 latest/stable snapcrafters -
snapd 2.46.1 9279 latest/stable canonicalâś“ snapd
341 root@white#

I can supply the typescript files if they’re needed for future reference.

Many thanks for your help.

Regards,
Colin

PS: How do we mark this as closed or solved?

1 Like

There should be a “Mark as solution” button somewhere on one of the replies here I think