Snap apps won't start

I had snapd with snap-store up and running for a few days now. I installed SQuirrel SQL and HeidiSQLtoday to see my options with DB managers.

I didn’t have the DB driver in Squirrel SQL so I removed it, and when I wanted to run HeidiSQL, it hanged on startup (the green progress bar, probably Wine initialization, can’t remember what it said).

Since HeidiSQL didn’t start properly, I decided to reboot the OS.

After rebooting, apps such as Discord, Pomatez and other snaps I used no longer started in GUI. I tried to start them in the CLI and they all failed there as well (with the same error below).

I did a complete reinstall of snapd and snap-store (fresh install) and the problem still persists.

The error:

$ snap-store
/user.slice/user-1000.slice/session-1.scope is not a snap cgroup

I searched far and wide but nothing gave me the solution.

What should I do?

OS: Rocky Linux 9

Snap-store version: --edge (see this)

looks like a kernel problem, what is the full output of snap version ?

(wildly guessing i assume you got a kernel upgrade and something in your kernels cgroup handling changed that snapd does not get along with)

$ snap version
snap    2.56.2-1.el9
snapd   2.56.2-1.el9
series  16
rocky   9.0
kernel  5.14.0-70.22.1.el9_0.x86_64

I do not remember performing any upgrade:thinking: