Slack crashes on Ubuntu 18.04

I wanted to try slack on my Ubuntu 18.04 system:

zyga@kaedwen:~$ snap info slack
name:      slack
summary:   Team communication for the 21st century.
publisher: slack
description: |
  Caution: Slack for Linux is in beta. We’re still busy adding features and
  ironing out potential issues.
  Slack brings team communication and collaboration into one place so you can
  get more work done, whether you belong to a large enterprise or a small
  business. Check off your to-do list and move your projects forward by bringing
  the right people, conversations, tools, and information you need together.
  Slack is available on any device, so you can find and access your team and
  your work, whether you’re at your desk or on the go.
  Scientifically proven (or at least rumored) to make your working life simpler,
  more pleasant, and more productive. We hope you’ll give Slack a try.
  Stop by and learn more at:
snap-id: JUJH91Ved74jd4ZgJCpzMBtYbPOzTlsD
  - slack
tracking:    stable
installed:   3.0.5 (4) 146MB classic
refreshed:   2018-01-16 10:23:04 +0100 CET
  stable:    3.0.5 (4) 146MB classic
  candidate: ↑               
  beta:      ↑               
  edge:      3.0.5 (4) 146MB classic

The snap installed fine but didn’t start. There’s nothing in the console (or in the gui) when it attempts to start.

zyga@kaedwen:~$ slack

Upon closer inspection it crashes on startup:

zyga@kaedwen:~$ journalctl -n 1
-- Logs begin at Tue 2018-01-16 07:54:09 CET, end at Thu 2018-01-18 18:53:52 CET. --
sty 18 18:53:52 kaedwen kernel: slack[28336]: segfault at ffffffffffffe41c ip 00000000037dd162 sp 000

Thanks for your feedback! What’s the output of snap version please?

It is 2.30, regular version from the store

The same snap on 2.30 works fine on Ubuntu 17.10

Anything useful in ~/.config/Slack/logs/?

It crashes before that is created.

Can you give us a bone of some kind. Like, anything strange about your setup? What kernel (hence asking for snap version)? What desktop? Any other classic snaps work and this one doesn’t? e.g. does pycharm-community work?

1 Like

Also helpful, what is output to the terminal when you run slack from the command-line?

Check /var/log/syslog to see whether there is any further information about the segfault, such as a seccomp message (though being classic that is unlikely)

1 Like

There is no further information in syslog and there’s no output at all when running slack on command line. I did some more experiments and slack does start when I ssh -X from my artful system. It now feels to be X related.

This is a fresh install of Bionic desktop on an AMD (CPU and GPU) system that was running artful as my main development box. Nothing unusual about it and all the snaps I tried worked fine (on artful).

I installed and ran slack in 18.04. As @zyga-snapd said the command runs, but there is not output. I also noticed that when I quit the terminal where I’d run “slack” then it popped up.

It does work from the Activities (after a session restart which is needed for the shell to know about the new paths).

Edit: and now it works fine from the cli too.


It needed a session restart to work? That’s not ideal?

I thought most snaps came up in Activities immediately…

It works now… no idea why. Let’s say that was a bunch of cosmic rays. I rebooted my box.

Yeah, they do, my bad.

@zyga-snapd as given in a do-be-do podcast as exemplory.

I’m having the same problem on 18.04.

Slack version:
snap-id: JUJH91Ved74jd4ZgJCpzMBtYbPOzTlsD
tracking: stable
refresh-date: 13 days ago, at 13:53 CEST
stable: 3.2.1 (7) 150MB classic
candidate: ↑
beta: ↑
edge: 3.2.1 (7) 150MB classic
installed: 3.2.1 (7) 150MB classic

And this is the kernel log:
kernel: slack[9029]: segfault at 8 ip 00007f9c26583600 sp 00007ffd72854ac8 error 4 in[7f9c2656d000+4a000]

I found out, that this error only occurs, when my Laptop (Lenovo ThinkPad w530) is booted while docked.
Everything works fine, if booted outside the dock.

I have the same problem here. Fresh install of Ubutu 18.04 on Lenovo Ideapad.
When I login with a Ubuntu Wayland session Slack will crash on start. I have a second monitor connected, which is why I need Wayland to have different scalings.

Any tips on how to solve this?