Opera with Snapd on Manjaro error

Hello there,
I installed the OS Manjaro yesterday on my wonderful Raspberry Pi 4B (4GB) and searched for a way to get opera (my main browser) for this OS. Thats when I found Snapd. I went to the Add/Remove Software of Manjaro and installed Snapd. Today I wanted to install opera, but I just got an error:

error: cannot communicate with server: Post http://localhost/v2/snaps/opera: dial unix /runsnapd.socket: connect: no such file or directory

Then I searched a bit but didn’t found something, only that:

snap version
snap 2.24-2
snapd unavailable
series -

So, anyone? :smiley:

have you seen this howto yet ?

Yes… I have seen it and I have done it.

well, there are more things you need to do :slight_smile: this is why i asked, but if you enabled and started the socket service as described and it still doesnt work, there might be a bug …

Or its just not available for arm64…

i highly doubt it would be shown in your add/remove software tool if there was no arm64 version … but it does obviously not auto-start regardless how you install it and needs manual enabling/starting …

No, I mean opera. Snapd isn’t just for opera.
The problem is that I cant install opera. Maybe because there is no arm64 version of it.

oh, indeed … there is only an amd64 one, sorry, i didnt get that