Links from snap firefox won't launch snap zoom

There were recent updates to both Firefox and zoom and I believe I got the zoom update most recently. Since these updates, zoom meeting links opened in FF will not launch zoom. System Handler cannot seem to find it (not familiar with how that works ATM), and pointing to /snap/bin/zoom-client also does not work. I may try falling back to previous version, but looking for other options/troubleshooting tips.

sorry, zoom changed quite dramatically with the last release, i’m still battling with the fallout of this and only got notified about this particular problem last night, i’ll try to find a fix over the weekend.

note that you can always just snap revert zoom-client to go back to the former version on disk when such things happen …

1 Like

Hey, @ogra! Big fan of the snap and it is appreciated!! Definitely understand these things happen.

I reverted and things are working. Care to reply here when the fix is ready to test?

Another thing to alert you on is that it was also not working with “Same as System” audio settings with that version.

Finally, is there a way to make sure zoom won’t auto update over the weekend?

yup, will let you know

that does seem to work fine for me here on a 20.04 install … i note that it breaks when i switch the hosts audio input during a running session of zoom though and zoom only picks up the change after restarting the app …

see:

you can set update schedules for snaps … (not per-snap though but in general you can avoid snap updates on a weekend this way)

3 Likes

Just to tag along on the same thread, on some of my 20.04 systems the latest zoom client won’t start anymore at all. I’m not sure if it’s relevant, but the system that works has intel graphics while the system that broke has AMD graphics. There is no error message but when I run with strace the last entries are as follows:

[pid 488567] futex(0x7f347786ff38, FUTEX_WAKE_PRIVATE, 2147483647 <unfinished ...>
[pid 488551] --- SIGTRAP {si_signo=SIGTRAP, si_code=SI_KERNEL} ---
[pid 488550] <... futex resumed>)       = 0
[pid 488549] <... read resumed>)        = ? <unavailable>
[pid 488548] read(2005335808,  <unfinished ...>
[pid 488546] ????( <unfinished ...>
[pid 488571] <... futex resumed>)       = ?
[pid 488569] <... poll resumed> <unfinished ...>) = ?
[pid 488567] <... futex resumed>)       = ?
[pid 488552] <... futex resumed>)       = ?
[pid 488547] <... epoll_wait resumed> <unfinished ...>) = ?
[pid 488546] <... ???? resumed>)        = ?
[pid 488528] <... poll resumed> <unfinished ...>) = ?
[pid 488520] <... futex resumed>)       = ?
[pid 488568] <... poll resumed> <unfinished ...>) = ?
[pid 488568] +++ killed by SIGTRAP (core dumped) +++
[pid 488571] +++ killed by SIGTRAP (core dumped) +++
[pid 488572] +++ killed by SIGTRAP (core dumped) +++
[pid 488570] +++ killed by SIGTRAP (core dumped) +++
[pid 488569] +++ killed by SIGTRAP (core dumped) +++
[pid 488567] +++ killed by SIGTRAP (core dumped) +++
[pid 488552] +++ killed by SIGTRAP (core dumped) +++
[pid 488550] +++ killed by SIGTRAP (core dumped) +++
[pid 488549] +++ killed by SIGTRAP (core dumped) +++
[pid 488548] +++ killed by SIGTRAP (core dumped) +++
[pid 488547] +++ killed by SIGTRAP (core dumped) +++
[pid 488546] +++ killed by SIGTRAP (core dumped) +++
[pid 488528] +++ killed by SIGTRAP (core dumped) +++
[pid 488530] <... ppoll resumed>)       = 1 ([{fd=3, revents=POLLIN|POLLHUP}])
[pid 488529] <... ppoll resumed>)       = 1 ([{fd=3, revents=POLLIN|POLLERR|POLLHUP}])
[pid 488530] recvmsg(3, {msg_name=NULL, msg_namelen=0, msg_iov=[{iov_base="", iov_len=12288}], msg_iovlen=1, msg_controllen=0, msg_flags=0}, 0) = 0
[pid 488529] recvmsg(3,  <unfinished ...>
[pid 488530] exit_group(0 <unfinished ...>
[pid 488529] <... recvmsg resumed>{msg_namelen=0}, 0) = -1 ECONNRESET (Connection reset by peer)
[pid 488530] <... exit_group resumed>)  = ?
[pid 488529] exit_group(0)              = ?
[pid 488551] +++ killed by SIGTRAP (core dumped) +++
[pid 488520] +++ killed by SIGTRAP (core dumped) +++
[pid 488519] <... wait4 resumed>[{WIFSIGNALED(s) && WTERMSIG(s) == SIGTRAP && WCOREDUMP(s)}], 0, NULL) = 488520
[pid 488519] --- SIGCHLD {si_signo=SIGCHLD, si_code=CLD_KILLED, si_pid=488520, si_uid=1000, si_status=SIGTRAP, si_utime=30, si_stime=15} ---
[pid 488519] write(2, "zoom was exited due to a handled"..., 44) = 44
[pid 488519] write(2, "ZoomLauncher exit.\n", 19) = 19
[pid 488519] exit_group(0)              = ?
[pid 488519] +++ exited with 0 +++
[pid 488441] <... wait4 resumed>[{WIFEXITED(s) && WEXITSTATUS(s) == 0}], 0, NULL) = 488519
[pid 488441] --- SIGCHLD {si_signo=SIGCHLD, si_code=CLD_EXITED, si_pid=488519, si_uid=1000, si_status=0, si_utime=0, si_stime=0} ---
[pid 488441] rt_sigreturn({mask=[]})    = 488519
[pid 488441] dup2(11, 1)                = 1
[pid 488441] close(11)                  = 0
[pid 488441] dup2(12, 2)                = 2
[pid 488441] close(12)                  = 0
[pid 488441] read(10, "", 8192)         = 0
[pid 488441] exit_group(0)              = ?
[pid 488441] +++ exited with 0 +++
[pid 488530] +++ exited with 0 +++
+++ exited with 0 +++

Huge thanks, this solved the issue for me as well. Appreciate you taking the time to fix it. I really enjoy having Zoom in a Snap!

As a note the version that is working with Firefox zoommtg xdg links is 5.9.6.2225.

Seems to be the same issue on GitHub, xdg-open doesn’t start zoom

I know I marked this as solved, but am now getting an alert for a zoom update.

Thought I would post if there is a fix for the next version?

there is a new version in edge, did you try this one to see if opening links with it still works ?

I would be happy to if I could verify a way to not only switch back from edge, but also rollback to the version in the normal channel.

the stable channel should have the last good version (i rolled that back a while ago)… so just switching back and forth between edge and stable should be okay …

I was able to switch to latest/edge and links were still not being handled by the System Helper.

Rolling back to latest/stable restored functionality.

Should we start a new forum thread for this or go to your zoom-client project to continue? We kinda already marked this as solved is why I ask

@ogra I thought I would check up on this. I think we are still held back at 5.9.6.2225 on latest/stable.

There may be some issues with zoom that need updates here.

Let me know if I should try latest/edge again. I haven’t tried it since the 16th. Links were not being handled by the System Helper.

there was an update on the zoom side two days ago and the auto-build has properly picked it up and released to edge yesterday …

sadly the broken behavior persists … i did some research on this and found that the ZoomLauncher binary simply ignores all startup options once started with a handed over URL …

that sadly includes the --no-sandbox option which is needed when running it inside an already existing sandboxed setup like snap/flatpak, so it tries to spawn an additional sandbox inside the already established one, this makes it fail …

… funnily when launching it without any additional url or option the --no-sandbox switch is respected just fine, something has changed internally in the zoom binary with 5.10 that i can not really easily work around …

looking at the flatpak, they seem to have hit the exact same error and work around it through an awful LD_PRELOAD hack that essentially replaces a ton of internal chromium calls in the zoom binary …:

I have to drop back to the deb package. However, I am happy to help test. Just let me know.

I much appreciate the work on getting a Zoom snap, though sadly I’ve had to swap back to the .deb package as well, since Zoom links aren’t opening for me in Firefox either. It might be some kind of permissions thing on my end though, since I’m running Firefox as a “snap” as well.