Libreoffice 6.0.3 not so stable


#1

I have reported this problem for some time not allowing me to save my documents, as an alternative to it (and possibly more efficient) install the flatpak package and this does not stop the team in charge of snapd and snap libreoffice

b5132bb80618855dc2e376d6739f29383a0f5008_1_690x387

jorge@jorge-Lenovo-ideapad-110-15ISK:~$ snap run libreoffice.writer
Gtk-Message: Failed to load module "unity-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module “canberra-gtk-module”

(soffice:4301): GLib-GIO-WARNING **: Error creating IO channel for /proc/self/mountinfo: Permission denied (g-file-error-quark, 2)

same results with Impress


#2

Thanks for the report @jor1196. Where are you trying to save the document?


#3

tried in my user folder, where before if I could do it perfectly but now I can not


#4

Can you please share the output of the following commands?

snap info core libreoffice | egrep "name|tracking|refreshed|installed"

echo $HOME

snap interfaces libreoffice

Thanks!


#5

I agree that the flatpak package seems somewhat more stable, but last time I tried to use it, it didn’t have Java support. Since I absolutely need certain extensions that require Java, that makes it not an option for me :frowning:


#6

jorge@jorge-Lenovo-ideapad-110-15ISK:~$ snap info core libreoffice | egrep "name|tracking|refreshed|installed"
name: core
tracking: stable
refreshed: 2018-04-05T18:16:52-03:00
installed: 16-2.32.3 (4407) 90MB core
name: libreoffice
tracking: stable
refreshed: 2018-04-04T12:51:36-03:00
installed: 6.0.3.2 (59) 479MB -
jorge@jorge-Lenovo-ideapad-110-15ISK:~$ echo $HOME
/home/jorge
jorge@jorge-Lenovo-ideapad-110-15ISK:~$ snap interfaces libreoffice
Slot Plug
:cups-control firefox,libreoffice
:desktop eog,evince,firefox,gedit,gimp,gnome-calculator,gnome-chess,gnome-clocks,gnome-mines,gnome-system-monitor,libreoffice,spotify,telegram-desktop,vlc
:gsettings eog,evince,firefox,gedit,gimp,gnome-calculator,gnome-chess,gnome-clocks,gnome-mines,gnome-system-monitor,libreoffice,spotify,telegram-desktop
:home eog,evince,firefox,gedit,gimp,libreoffice,spotify,telegram-desktop,vlc
:network eog,evince,firefox,gedit,gnome-calculator,gnome-chess,libreoffice,spotify,telegram-desktop,vlc
:network-bind libreoffice,telegram-desktop,vlc
:opengl firefox,gimp,libreoffice,spotify,vlc
:pulseaudio firefox,gnome-chess,gnome-clocks,gnome-mines,libreoffice,spotify,telegram-desktop,vlc
:removable-media libreoffice,vlc
:unity7 eog,evince,firefox,gedit,gimp,gnome-calculator,gnome-chess,gnome-clocks,gnome-mines,gnome-system-monitor,libreoffice,spotify,telegram-desktop,vlc
:wayland eog,evince,gedit,gimp,gnome-calculator,gnome-chess,gnome-clocks,gnome-mines,gnome-system-monitor,libreoffice,spotify

  •             libreoffice:bluez
    

jorge@jorge-Lenovo-ideapad-110-15ISK:~$


#7

I had the exact same problem and the weird thing was that nothing was apparent. I would edit a spreadsheet, exit, confirm save (in a folder below ~), no warnings or problems. File access time never changed and none of the changes was recorded. I remember an old blogpost that said to install in classic mode so did and everything is fine. I was switching over to all snaps when available and just assumed I still needed to install in this mode and had forgotten.


#8

libreoffice is a strictly confined snap, it’s not meant to install in classic mode (I don’t think passing --classic to the snap install command would do anything, actually).


#9

Everything looks alright there. What’s your distribution (output of lsb_release -a) and what’s the filesystem type of the partition where your home sits (output of mount | grep home)?

Are you seeing apparmor denials related to libreoffice when saving a document fails? You can monitor those by running the following command in a terminal while running libreoffice:

journalctl -f | grep libreoffice

#10

That’s what I was expecting. I hadn’t tried it in a while and just assumed I was wrong so re-installed with the flag so I guess I can’t really say what the actual problem was because now it works. I have some fresh installs coming up so I’ll keep track.
I couldn’t use it that way so had to solve the problem within hours so don’t have much good info, but is it possible that the fact I was starting LO by double clicking on existing .ods files affect anything? Or that I had switched to the snap version after completely uninstalling an up to date PPA apt install? Just tossing things out in case anything clicks.


#11

No, that shouldn’t affect the way libreoffice is being run (and confined). And the coexistence of the two packages (deb and snap) shouldn’t be a problem either.


#12

I wonder if this is simply another instance of: Bug? Saves are blocked to $SNAP_USER_DATA if snap updates when it is already running


#13

That’s failing to save a document to $HOME, not $SNAP_USER_DATA.

@jor1196, you’re not trying to save to a path below a hidden directory (one that starts with a dot), are you? Because the home interface doesn’t allow that. So saving to $HOME/.documents is intentionally disallowed, whereas saving to $HOME/documents is permitted.

Are you still seeing the issue across reboots?


#14

I was not saving anything in hidden directories


#15

#16

The following denial looks suspicious (and possibly related):

abr 20 03:50:40 jorge-Lenovo-ideapad-110-15ISK audit[24842]: AVC apparmor=“DENIED” operation=“mknod” profile=“snap.libreoffice.writer” name=2F686F6D652F6A6F7267652F2E7E6C6F636B2E53696E2074C3AD74756C6F20312E6F647423 pid=24842 comm=“soffice.bin” requested_mask=“c” denied_mask=“c” fsuid=1000 ouid=1000


#17

Use aa-decode for this:

$ echo abr 20 03:50:40 jorge-Lenovo-ideapad-110-15ISK audit[24842]: AVC apparmor=“DENIED” operation=“mknod” profile=“snap.libreoffice.writer” name=2F686F6D652F6A6F7267652F2E7E6C6F636B2E53696E2074C3AD74756C6F20312E6F647423 pid=24842 comm=“soffice.bin” requested_mask=“c” denied_mask=“c” fsuid=1000 ouid=1000 | aa-decode
abr 20 03:50:40 jorge-Lenovo-ideapad-110-15ISK audit[24842]: AVC apparmor=“DENIED” operation=“mknod” profile=“snap.libreoffice.writer” name="/home/jorge/.~lock.Sin título 1.odt#" pid=24842 comm=“soffice.bin” requested_mask=“c” denied_mask=“c” fsuid=1000 ouid=1000

Ie name="/home/jorge/.~lock.Sin título 1.odt#". This is trying to create a hidden lockfile in the ~, which is not allowed.


#18

That makes sense. Libreoffice wants to create a lock file next to the saved file, and the home interface doesn’t allow that in $HOME (but it does in subdirectories).

@jor1196: saving the file anywhere in a subdirectory of $HOME should work, can you please test and confirm?


#19

Brand new minimal install of 18.04 Beta 2. Snap install LO. Can not create a lock file in the $HOME but everything works fine in ~/Documents.


#20

there are no problems in the subdirectories