How to run chromium in another language?

Hi,

is there a way to run Chromium in another language ?
( Equivalent instruction of ‘env LANGUAGE=es chromium-browser’ when Chromium is installed with apt)

Thanks

Yes, the same thing should work with the snap:

env LANGUAGE=es chromium

(tested with es and zh-CN).

1 Like

Doesn’t work here…
Chromium keeps the default language settings even launched this way

Can you share details about your OS, version, desktop environment?
Do other apps behave as you expect when you set LANGUAGE like this?

chromium  89.0.4350.4  latest/edge

snap version
snap    2.48+git661.g2997c48
snapd   2.48+git661.g2997c48
series  16
ubuntu  20.10
kernel  5.8.0-33-generic

Do other apps behave as you expect when you set LANGUAGE like this?

Any app installed with apt
Doesn’t work with apps installed with snap

I just tested again, this time with snapd and chromium from the edge channel, to mimick your environment, but this still works as expected.

What is your desktop environment? Does this affect all snaps, or just chromium?

gnome-shell --version
GNOME Shell 3.38.1

Not all snaps affected
Works with keepassxc
Doesn’t work with telegram-desktop & chromium

Is it possible that Chromium and Telegram Desktop were already running at the time you tried them? A number of applications implement a “single instance” mode, where running the program a second time just asks the original invocation to open a new window. It’s quite likely that things like the LANGUAGE environment variable won’t be communicated to the original process.

2 Likes

No they weren’t running

Sorry, I hadn’t checked properly
The following process was still running:
/snap/chromium/1434/usr/lib/chromium-browser/chrome
killed it
Now ‘env LANGUAGE=es’ chromium is working fine…

However it does not work for telegram-desktop
Perhaps due to the fact that telegram has a built-in language selection.

I don’t know if this is a rule for applications installed with snap but simply quitting an application is apparently not enough, you have to go and check if other processes related to this application are still in progress

I don’t think this is at all related to whether the app is packaged as a snap or not.

An application like Telegram is likely to have a mode to run in the background when you close its window, since it needs to be running to notice when the user receives messages.

Not any process is running when Telegram closed:

ps -d | grep -i telegram

Chromium on the other hand, even closed:

ps -d | grep -i chrome
 130180 ?        00:09:02 chrome
 130253 ?        00:00:00 chrome
 130254 ?        00:00:00 chrome
 130256 ?        00:00:00 chrome
 130275 ?        00:11:47 chrome
 130278 ?        00:02:43 chrome
 130282 ?        00:00:01 chrome
 130324 ?        00:01:03 chrome
 130377 ?        00:00:00 chrome
 130432 ?        00:00:00 chrome
 130445 ?        00:00:40 chrome
 130451 ?        00:00:31 chrome
 130471 ?        00:00:00 chrome
 130472 ?        00:00:37 chrome
 130473 ?        00:00:00 chrome
 130504 ?        00:00:02 chrome
 130516 ?        00:00:00 chrome
 130526 ?        00:00:01 chrome
 130542 ?        00:00:02 chrome
 130547 ?        00:00:14 chrome
 130555 ?        00:00:24 chrome
 130569 ?        00:00:32 chrome
 134923 ?        00:00:21 chrome
 190706 ?        00:00:00 chrome
 190789 ?        00:00:00 chrome

Do you happen to have the preference to keep chromium webapps running in the background enabled? That’s the first option in chrome://settings/system, and if it’s on it would explain why you still have those processes running even after closing chromium.

1 Like

Do you mean this:

Windows and Linux

To close background apps when you close all Chrome tabs, follow these steps:

  1. In Chrome, at the top right, click MoreMore icon.
  2. At the bottom, click Show advanced settings .
  3. In the “System” section, uncheck the box next to “Continue running background apps when Google Chrome is closed.”

You’re right, it was activated
I will deactivate and recheck

Don’t know if it has something to do with this:
Default Chromium fonts are missing after snapd has been updated

That was it…
No more process in the background
Waiting for next snapd update to check if this helps with the problem of default fonts vanishing

No change after last snapd update…