Error installing musescore on ChromeOS

Hi, all. I am trying to install MuseScore on a Chromebook with the new Chrome OS 80 (so, Debian Stretch). (Edit: oops … Buster, not Stretch, it was Stretch in Chrome OS 79) I have a Lenovo C330, which is ARM-64 bit, not Intel. I ran the “sudo snap install musescore” from the terminal, and after a bunch of activity I get this error message:

error: cannot perform the following tasks:

  • Download snap “core” (8691) from channel “stable” (unexpected EOF)

I’m a Linux newbie and my ignorance cannot be exaggerated – I know nothing. Is that error on the Snap side or on the MuseScore side? Should I be posting over there, or might someone here be able to help?

Thanks a million

1 Like

anyone? does this error make sense to someone? Over on the Musescore forum they said to ask here. Thanks all.

I’m the maintainer of the MuseScore snap, but I don’t have any Chromebook, so I’m not really sure about this, but I would bet that it’s a problem with snap running on Chrome OS (didn’t even know that was possible). Did you try installing other snaps?

Thanks for answering, Marc. Yes, Chrome OS 80 (just released) runs Debian Buster (containerized, if that makes sense).

[Edited to remove a link to an outside article – was that why it was flagged?]

I have not installed any other snaps. Never done anything with Linux. Can you recommend a little one I could use as a tester?

Look, I just tried to post another reply with the error messages I get when trying to install another snap, to test out the process, and somebody flagged it – multiple users flagged it, it says, with no explanation of what I said wrong. Now I’ve gone and deleted it, but this is making me feel even more handicapped in trying to figure out the issue. What’s up?

did you see:

perhaps there is something helpful in it ? (in general chromebooks are typically lacking a lot of kernel features to properly use snaps on them (as you can see by the multiple posts about issues with them in this forum) so your mileage may vary)

Thank you, I’ll read it. Oh, and it does have ARM64-specific guidance, too. Hopefully this will solve my problems, I’ll report back either way. Thanks for the tip.

OK, so I went through that article and all went well until I tried to install snap-store at the end. I get the same error I got with musescore: cannot

download snap “core” (8691) from channel “stable” (unexpected EOF)

Could it be because it’s aborting prematurely? In addition to having primitive hardware, I also have pretty poor WiFi.

yeah, that could well be a network issue indeed … or a proxy one in case you use a proxy server in your network.

OK, I’ll just keep trying, then. Sometimes I have to start a thing over and over before it finally takes. I’m kind of embarassed to say, I use my mobile phone’s data connection as a wifi hotspot … so yeah, it’s pretty minimal. I mean, it’s LTE, and I have no issues with it for normal web browsing. But it’s not like cable or FIOS.

Wow, I just got a much longer error message:

I hope that works, I don’t know if I can just paste a screenshot image here.

If you’re having network problems, you could try just downloading the snaps and then installing them manually with:

$ snap download core
$ snap ack core*.assert
$ snap install core*.snap
$ snap download musescore
$ snap ack musescore*.assert
$ snap install musescore*.snap

I used to experience SNAP install timeouts - albeit without any error messages such as EOF. It looked like my computer could reach the SNAP store but then something would time out and it would skip the installation.

I wrote a little script to sit there in a loop until the SNAP was installed:

installed=$(snap list)
while [[ ! $installed =~ .kdenlive. ]];
echo “Waiting For Kdenlive”
snap install kdenlive
installed=$(snap list)

Is your mobile phone with a reputable provider? … Is it 4g … as ogra has mentioned above a proxy might be the problem, With the quality of the mobile these days other than that there shouldn’t be a problem, however where I am just 105km north of Sydney (Capital city of NSW), Australia, Optus cuts out between my back door and the clothes lines. I have also noticed this can happen in the junction of mobile towers when the SIM is moving between them.

And only call yourself good things ! You are good !

I was just about to break down and get Fios installed, but this morning someone helped me get musescore installed and working via flatpak. They’re both version 3.4.2, but I’m going to bookmark this page in case I have any issues with that one, I’ll come back and try your suggestion. Thanks a lot.

1 Like

Does flatpak place a menu item to start the app or does it have to be started command line?

I think Oracle purchased Red Hat so I have this little question in the back of my mind about the future of flatpak support and security updates - they are proprietary organisation.

Aw, thanks for the kind words. Yes, it’s a reputable provider, and it’s LTE. But I’ll tell you, installing Chrome’s Linux package “Crostini” took hours and hours, with repeated messages of something like “connection interrupted” (I forget what exactly). Like I told ijohnson above, I almost got Fios (high-speed via fiber-optic cable) but just this morning I managed to get this package installed by flatpak.

Flatpak did place a menu item to start the app.

Does this also establish the scheduled updating / refreshing ?

I don’t know, Michael.

I also don’t know why more of my posts have been flagged and deleted. If people are going to flag my posts, would you please do me the courtesy of sending me a PM to tell me what exactly I said wrong? Otherwise, it’s going to make it pretty difficult to carry on a conversation here. If The flatpak one turns out to be a problem, how am I going to come back here to ask for advice?

Yes it will still refresh because you specifically ran snap ack.

that was actually IBM :slight_smile:

1 Like