Dependencies not updated / installed when updating snaps?

As per this issue, it seems dependencies (in this case, KDE Frameworks 5) of installed snaps (in this case, KeePassXC) are not automatically installed / updated when the snap package is updated.

Point in case, my 2 systems (Ubuntu Studio 22.04 and Pop!OS 22.04) recently automatically updated to KeePassXC 2.7.8. Right after updating, KeePassXC fails to run without any error shown to the user.

When running keepassxc from the console, the following error is thrown: ERROR: not connected to the kf5-5-113-qt-5-15-11-core22 content interface.

After some digging, I found out the kf5-5-113-qt-5-15-11-core22 snap package was missing (which could be seen as an issue on it’s own - why doesn’t snap provide more useful info such as ERROR: kf5-5-113-qt-5-15-11-core22 package not installed. ?).

After manually installing this package, KeePassXC worked flawlessly again.

Other users mentioned they removed and re-installed KeePassXC in order to work around this issue (probably because they, like me at first, had no idea they could simply install the missing dependency), but this leads to the existing config being purged as well (quite a pita if you forgot to make a backup). However, this also means that this issue only surfaces when upgrading existing snaps.

The maintainer of KeePassXC insists this is a snapd issue, and has tried to get it fixed back in 2022. Fast forward 2 years and the issue is still here. As a matter of fact, the maintainer is so fed up with snaps because of issues like this, he’s on the verge of abandoning Snap in favor of Flatpak :worried: Personally, I think both formats have their issues and benefits, and I’d prefer sticking to snap if possible. So in an effort to move it ahead, I’m posting here.

What can I do to help fix this issue?

1 Like

Thanks for your reply @angela683 . I think I did all of the above (except for contributing code as my skillset is unfortunately lacking in that area), and also added info to the bugreport on Launchpad.

How should I go about advocating for improvement, besides posting here and on Launchpad?

Ignore angela683 - they’re spam bot, now deleted…

1 Like

Thanks @popey. For a spam bot, she was actually not that unhelpful :wink:

1 Like

They’re unhelpful when they add the phishing link in later. Well, less helpful I guess if you ignore the one letter in blue!

For this problem this vaguely reminds me of similar discussions recently in another snap, Opera, where the tl;dr was store policies were overriding the autoconnection of the content interface.

Is it possible the same is going on here? When I look at KeepassXC I see:

interface                                 Plug                                   Slot                                                          Notes
content[icon-themes]                      keepassxc:icon-themes                  gtk-common-themes:icon-themes                                 -
content[kf5-5-113-qt-5-15-11-core22-all]  keepassxc:kf5-5-113-qt-5-15-11-core22  kf5-5-113-qt-5-15-11-core22:kf5-5-113-qt-5-15-11-core22-slot  -
content[sound-themes]                     keepassxc:sound-themes                 gtk-common-themes:sound-themes                                -
dbus                                      -                                      keepassxc:session-dbus-interface                              -

An unconnected DBus plug (I’m sure there are valid reasons but this one doesn’t look like one to me?, especially given it clearly isn’t necessarily as it being unconnected by default doesn’t break “much”), and in the assertion:

type: snap-declaration
format: 1
authority-id: canonical
revision: 1
series: 16
snap-id: jf2HsR51rlftaREcwhtxiEcDc76gL4O6
publisher-id: apCKcXygvsIEvn1HNfO28dUQ4l82DFEE
          name: org.keepassxc.KeePassXC.MainWindow
    deny-auto-connection: true
snap-name: keepassxc
timestamp: 2022-03-02T20:19:16.684500Z
sign-key-sha3-384: BWDEoaqyr25nF5SNCvEv2v7QnM9QsfCc0PBMYD_i2NGSQ32EF2d4D0hqUel3m8ul

@alexmurray Does this look similar to you as was with Opera?

@James-Carroll unfortunately this doesn’t appear to be the same issue - in this case keepassxc has no existing content plug rules defined - so this feels more like a bug in snapd to me - @pedronis @zyga can you comment?


I have reproduced this over weekend. I’ll look at what might be going on soon.