Cannot install snap file: snap is unusable due to missing files

Scratch builds are running, I plan to push out the builds in a bit. The update will be submitted today. How fast it gets from testing to the stable repository depends solely on people willing to test it.

1 Like

I’ve submitted a bunch of updates to Fedora just now:

1 Like

Thank you, Maciej👍, tested - it works - just installed Intellij Idea with snap!


Fix tested on Fedora 34. Worked perfectly. Installled snap-store finally.

Do you have a FAS account? can you give thumbs up in the bodhi snapd update page? This will speed up the process of moving snapd update to stable.

I’ll see if I can get a FAS account and tell my story. Doing work stuff at the moment so it may be a few.

Account created, knowledge shared. Hope it helps.


i am not an expert on linux, but i tried add the repo of RPMfusion-nonfree and RPMfusion-free, i also tried to install flathub repositorie.

Then it should work for you.

Kali gets this package straight from Debian testing. In this particular case, there’s a fix in Debian unstable (snapd version 2.51.7-1). I just imported this package in Kali rolling so that users can get the fix asap.

Therefore users of Kali rolling should just update their system and be good to go:

apt update && apt -y upgrade



No, this is completely unrelated to RPMFusion.

Thanks for your nice job!!!