Cannot install snap file: snap is unusable due to missing files

Hi, today a random user who was trying to install one of my application reported this weird error while they were trying to install one of my application called ktube-media-downloader, he sent me the screenshot of what is happening while they were trying to install the app. I am attaching the same below:
The screenshot reports “cannot install snap file: snap is unusable due to missing files” for both installs of ktube-media-downloader and qt551 content snap. Can someone from the snapd team confirm what is going on here? I looked in the forum already found nothing relevant. I tried to test the case myself by completely removing (and purging) both the snaps, both installed perfectly fine here on my test system (Ubuntu 16.04) which has snap --version:

snap    2.51.3 
snapd   2.51.3
series  16
ubuntu  16.04
kernel  4.4.0-211-generic


I can’t help but notice that the user from the screenshot seems to have their hostname as “…-macbookpro…”, are they running on Linux or in a container on a Mac? If so then snap install will fail and is not supported, though I thought we had a more obvious message in that case…

Getting snap version from this user would be most helpful

1 Like

Can the user run unsquashfs -v and attach the output? Looks suspiciously familiar to the problem I’ve observed on Arch with squashfs-tools 4.5, and the proposed fix is right here:

(That is assuming it’s even a Linux system as Ian has pointed out).

1 Like

I have requested same from the user.

I mailed and requested, waiting for user response.

I don’t know if it is right to post here.
I am having the same problem on both manjaro and arch linux.
journalctl -u snapd result
unsquashfs version 4.5

@ijohnson the user have Garuda Linux installed on their system.

@ijohnson snap --version output provided is:

snap version

@mborzecki unsquashfs -v provided by user is:

unsquashfs version

I hope this will help resolve the issue.

Then it sounds like a problem with squashfs 4.5, which should be fixed once lands. I have already fixed this in the Arch package, so maybe they just need to rebuild snapd from AUR.

1 Like

Hi! I am encountering a similar issue on Fedora, which apparently was introduced by a system update of a few days ago (unsure). snap suddenly stopped working, I noticed this while was performing a simple snap refresh command. I am unable to run any snap applications now. I tried force reinsalling snapd through dnf with no luck. I tried reinstalling the snapd rpm package as well, no changes.

snap refresh now currently shows the following error:

error: cannot perform the following tasks:

  • Mount snap “snapd” (12704) (snap is unusable due to missing files; contact developer)
  • Mount snap “core” (11420) (snap is unusable due to missing files; contact developer)

current output of snap --version :

snap 2.51-3.fc35 snapd 2.51-3.fc35 series 16 fedora 35 kernel 5.13.0-58.fc35.x86_64

output of snap list to show current core versions :

core 16-2.51.1 11316 latest/stable canonical✓ core core18 20210611 2074 latest/stable canonical✓ base core20 20210702 1081 latest/stable canonical✓ base

Also, now I get the same “snap is unusable due to missing files; contact developer)” error when trying to install any other snap application. Needless to say, it is impossibile to run any existing snap application as it will fail.

Any advice? thank you :slight_smile:

Thanks for reporting this. I’ll prepare a new build of snapd for rawhide.

much appreciated! Should you need anyone for testing it out, I’m available.

The update has been pushed. You can eithr grab the rpms from the build linked in the update info here: or wait for the update to be available once the respositories get refreshed.

1 Like

Great! I am ready to unpack the update, however I am missing glibc >= 2.33.9000-55.fc35 which is required by snapd and seemingly impossible to find anywhere (tried and rpm to no avail). Any ideas where to find it for Rawhide on the x86_64 arch?

Quite possible that the repositories have synced and contain the right version of glibc already. If it’s not the case you can always run rpm -Uvh --nodeps with the package files you download directly from koji.

I’m still seeing this on a fresh install of Fedora 34. Mount snap “snapd” (12883) (snap is unusable due to missing files; contact developer).

snap 2.51-1.fc34
snapd 2.51-1.fc34
series 16
fedora 34
kernel 5.13.12-200.fc34.x86_64

Any help would be appreciated. Getting unrecognized arguments with using the -Uvh --nodeps option.

Can you file a bug for snapd in RHBZ? I see that squashfs-tools update to 4.5 was submitted to 4.5 testing no longer than 3 days ago and it’s already in stable.

edit: if possible then please downgrade to squashfs-tools-4.4-4.git1.fc34 while I prepare an update of snapd.

Same problem on kali-rolling (31 August 2021)
I assume it will be fixed when they push the latest version to their repo

Just in case it’s useful, this seems to be causing a fail in the build of the snapcraft ansible role

and the raw log of the failure can be accessed from there (this link may work for you too) which contains the error message

“stderr”: “error: cannot perform the following tasks:\n- Mount snap “core” (11606) (snap is unusable due to missing files; contact developer)\n”

I don’t know where kali-rolling gets their packages from so you may need to consult your favourite distro’s forum.

Hi, mborzecki, guys, could you please clarify, does this fix plan to appear in fc34 and when?