Cannot install snap file: snap is unusable due to missing files

The update has been pushed. You can eithr grab the rpms from the build linked in the update info here: or wait for the update to be available once the respositories get refreshed.

1 Like

Great! I am ready to unpack the update, however I am missing glibc >= 2.33.9000-55.fc35 which is required by snapd and seemingly impossible to find anywhere (tried and rpm to no avail). Any ideas where to find it for Rawhide on the x86_64 arch?

Quite possible that the repositories have synced and contain the right version of glibc already. If it’s not the case you can always run rpm -Uvh --nodeps with the package files you download directly from koji.

I’m still seeing this on a fresh install of Fedora 34. Mount snap “snapd” (12883) (snap is unusable due to missing files; contact developer).

snap 2.51-1.fc34
snapd 2.51-1.fc34
series 16
fedora 34
kernel 5.13.12-200.fc34.x86_64

Any help would be appreciated. Getting unrecognized arguments with using the -Uvh --nodeps option.

Can you file a bug for snapd in RHBZ? I see that squashfs-tools update to 4.5 was submitted to 4.5 testing no longer than 3 days ago and it’s already in stable.

edit: if possible then please downgrade to squashfs-tools-4.4-4.git1.fc34 while I prepare an update of snapd.

Same problem on kali-rolling (31 August 2021)
I assume it will be fixed when they push the latest version to their repo

Just in case it’s useful, this seems to be causing a fail in the build of the snapcraft ansible role

and the raw log of the failure can be accessed from there (this link may work for you too) which contains the error message

“stderr”: “error: cannot perform the following tasks:\n- Mount snap “core” (11606) (snap is unusable due to missing files; contact developer)\n”

I don’t know where kali-rolling gets their packages from so you may need to consult your favourite distro’s forum.

Hi, mborzecki, guys, could you please clarify, does this fix plan to appear in fc34 and when?

Scratch builds are running, I plan to push out the builds in a bit. The update will be submitted today. How fast it gets from testing to the stable repository depends solely on people willing to test it.

1 Like

I’ve submitted a bunch of updates to Fedora just now:

1 Like

Thank you, Maciej👍, tested - it works - just installed Intellij Idea with snap!


Fix tested on Fedora 34. Worked perfectly. Installled snap-store finally.

Do you have a FAS account? can you give thumbs up in the bodhi snapd update page? This will speed up the process of moving snapd update to stable.

I’ll see if I can get a FAS account and tell my story. Doing work stuff at the moment so it may be a few.

Account created, knowledge shared. Hope it helps.


i am not an expert on linux, but i tried add the repo of RPMfusion-nonfree and RPMfusion-free, i also tried to install flathub repositorie.

Then it should work for you.

Kali gets this package straight from Debian testing. In this particular case, there’s a fix in Debian unstable (snapd version 2.51.7-1). I just imported this package in Kali rolling so that users can get the fix asap.

Therefore users of Kali rolling should just update their system and be good to go:

apt update && apt -y upgrade



No, this is completely unrelated to RPMFusion.

Thanks for your nice job!!!