Call for testing: VLC 3.0.0-rc1

I have installed the same version vlc in flatpak and the flatpak recognizes the language of my system, which in this case is Spanish.

/usr/share/libdrm/amdgpu.ids: No such file or directory
amdgpu_device_initialize: Cannot parse ASIC IDs, 0xffffffea.[00007f58bc001430] filesystem stream error: cannot open file /media/haug/data-1/movie/MyMovie.m2t (Permission denied)

Did you connect the removable-media snap interface first ?

Hey guys any update on this? I still have no fonts :frowning:

Seems https://bugs.launchpad.net/ubuntu/+source/libupnp/+bug/1571199
ls still present in vlc 3.0.0 … :frowning:
(the snap is a great opportunity to test if new features/fixes landed :wink: )

Installation went smoothly. When trying to play a dvd vlc complains about missing css key. Tested on kde neon

VLC RC8 still can’t access some mounted devices. I have an internal HDD mounted under /mnt/ called “Daten”.
sudo snap connect vlc:removable-media does not work for any media under /mnt/Daten/
There is a screenshot where you can see how the HDD is mounted and how VLCs error looks like.

https://s17.postimg.org/kz8cbbjzj/VLC_Snap_RC8.png

mount it under /media and it will work … the removable-media interface only allows access to devices monted there … (i guess even a bind mount would work if you want to keep the old location intact for scripts or whatnot)

1 Like

Vlc apparently does not access the regional settings, because it does not translate the language of the application into my regional language. When will this be implemented for vlc. Snap ?. The deb versions do.

So far it seems to function without issue. I mostly was streaming through youtube videos. the only issues I had were some of the same errors that others reported.

dustin  snap run vlc
VLC media player 3.0.0 Vetinari (revision 3.0.0-0-gef4c265)
[0000000001e943b0] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Gtk-Message: Failed to load module "gail"
Gtk-Message: Failed to load module "atk-bridge"
Gtk-Message: Failed to load module "canberra-gtk-module"
Qt: Session management error: None of the authentication protocols specified are supported

I’ve just reported upstream the issue causing the indicator-icon not to work properly: https://trac.videolan.org/vlc/ticket/19692

2 Likes

upnp (eg playing from DLNA servers) does not work (View/Playlist/Local Network/Universal Plug ‘n’ Play):

[00007f27ac619a80] upnp services discovery: Initializing libupnp on 'default' interface
[00007f27ac619a80] upnp services discovery error: Initialization failed: UPNP_E_SOCKET_BIND
[00007f27ac619a80] main services discovery error: no suitable services discovery module

I’ve read that this may be caused by: https://bugs.launchpad.net/ubuntu/+source/libupnp/+bug/1571199. It seems like vlc could either build a working upnp as part of the snap or maybe build a working deb, put it in a ppa, and stage-packages that deb.

1 Like

Been testing vlc and it works great, but with poor theme (like mentioned above). Anyone tried to install a plugin? Because I tried to install vlc-pause-click-plugin (https://github.com/nurupo/vlc-pause-click-plugin) without success. The plugin file (*.so) should be copied in /usr/lib/x86_64-linux-gnu/vlc/plugins/video_filter but snap has its own directory for the plugins that is read-only. Anyone know a way to add plugins?

IIRC, the plugin has to be integrated into the vlc snap for it to work.

is there not a way to add plugins to vlc?

while plugins is probably not easily possible to add, since the binaries need to be compiled against the specific headers of the vlc version you run, i think lua extensions are possible if you:

mkdir -p ~/snap/vlc/current/.local/share/vlc/lua/extensions

… and copy them into that dir … (untested …)

Apparently vlc (stable:3.0.1-4-g14a4897 and beta:3.0.1-16-g0703aa6) is not able to open files in other partitions. I have a partition in the same SSD as / where I keep my media files. I use symbolic links to replace some of my /home subfolders. In any case, vlc spits out a filesystem error and complains about not being able to open at that location.

[OFFTOPIC]

Does anyone have any idea how to use libvlc in development when installed using snap?

similar issue here

I can not read videos made by OBS Studio with vlc, this will be fix soon?

vlc stable 3.0.1-4-g14a4897 is almost always not able to connect to ALSA (fresh ubuntu Bionic install).
I say sometimes cause once a sudo chown $USER:$USER /usr/share/alsa/alsa.conf + reboot helped…
…but then another reboot will deactivate alsa again but only for snaps?
I have no clue but am willing to help!

Ends with an error similar to Spotify does not play audio and Call for testing: VLC 3.0.0-rc1

Can confirm audio works otherwise: able to open the same video with vlc from apt & from within Chrome.

∀ snap --version
snap 2.32.6
snapd 2.32.6
series 16
ubuntu 18.04
kernel 4.15.0-20-generic