Call for testing: VLC 3.0.0-rc1

Been testing vlc and it works great, but with poor theme (like mentioned above). Anyone tried to install a plugin? Because I tried to install vlc-pause-click-plugin ( without success. The plugin file (*.so) should be copied in /usr/lib/x86_64-linux-gnu/vlc/plugins/video_filter but snap has its own directory for the plugins that is read-only. Anyone know a way to add plugins?

IIRC, the plugin has to be integrated into the vlc snap for it to work.

is there not a way to add plugins to vlc?

while plugins is probably not easily possible to add, since the binaries need to be compiled against the specific headers of the vlc version you run, i think lua extensions are possible if you:

mkdir -p ~/snap/vlc/current/.local/share/vlc/lua/extensions

… and copy them into that dir … (untested …)

Apparently vlc (stable:3.0.1-4-g14a4897 and beta:3.0.1-16-g0703aa6) is not able to open files in other partitions. I have a partition in the same SSD as / where I keep my media files. I use symbolic links to replace some of my /home subfolders. In any case, vlc spits out a filesystem error and complains about not being able to open at that location.


Does anyone have any idea how to use libvlc in development when installed using snap?

similar issue here

I can not read videos made by OBS Studio with vlc, this will be fix soon?

vlc stable 3.0.1-4-g14a4897 is almost always not able to connect to ALSA (fresh ubuntu Bionic install).
I say sometimes cause once a sudo chown $USER:$USER /usr/share/alsa/alsa.conf + reboot helped…
…but then another reboot will deactivate alsa again but only for snaps?
I have no clue but am willing to help!

Ends with an error similar to Spotify does not play audio and Call for testing: VLC 3.0.0-rc1

Can confirm audio works otherwise: able to open the same video with vlc from apt & from within Chrome.

∀ snap --version
snap 2.32.6
snapd 2.32.6
series 16
ubuntu 18.04
kernel 4.15.0-20-generic