Call for testing: libreoffice 5.4.3


#1

Call for testing: libreoffice 5.4.3

Description

LibreOffice is a free and open source office suite, developed by The Document Foundation. The LibreOffice suite comprises programs for word processing, the creation and editing of spreadsheets, slideshows, diagrams and drawings, working with databases, and composing mathematical formulae.

losnap5432

How to install

snap install libreoffice --candidate

Note that the snap can coexist with the ubuntu packages. If you wish to remove the ubuntu packages to use solely the snap, you can do:

sudo apt remove "libreoffice*"
sudo apt autoremove

Requested Setups

At the moment that version of the snap is available for amd64 processors only. It is expected to work on any linux distribution that supports snaps, including on Wayland where previously it didn’t work.

Notes

This revision is a minor update from the one currently in the stable channel (5.4.2).
Since snapd 2.29 has been released, the snap doesn’t ship fonts any longer, instead it uses the ones on the host system exposed by the desktop interface.

Specific Tests

I’m interested in your feedback on any tasks you perform using all the apps in the libreoffice suite.
Please report any issues you encounter in this thread. Thanks!


Snap wishlist - suggestions wanted!
#2

It seems to work pretty smoothly except that it doesn’t see all my installed fonts (specifically those I put manually in ~/.fonts). Do I need to do something to make them accessible or is that not supported yet?

Running libreoffice 5.4.3.2 (43) on Ubuntu 17.10, Wayland session, amd64.


#3

This seems to be down to the way the confinement environment changes $HOME:

$ snap run --shell libreoffice
To run a command as administrator (user "root"), use "sudo <command>".
See "man sudo_root" for details.
$ ls /home/james/.fonts
[snip font files]
$ ls $HOME/.fonts
ls: cannot access '/home/james/snap/libreoffice/42/.fonts': No such file or directory

Unless snapd changes the way it alters $HOME, the best option might be to have snapcraft-desktop-helpers add a symlink from the confined ~/.fonts to the real ~/.fonts, similar to how it symlinks the dconf settings database if it is readable.

There are also fontconfig cache files under ~/.fontconfig, but I’m not sure if they’d be usable with the symlinked path names though: the cache files are keyed off the path name which will be different. So there will probably be a minor hit while it generates new cache files on the first run.


#4

Fonts installed locally in ~/.fonts should now be visible with the updated version in the candidate channel. Please test again! Note that fonts in ~/.local/share/fonts are not visible yet due to a missing rule in the apparmor base abstraction for fonts, but this is being addressed.


#5

Indeed. My LO just updated to release 44 and now it works. Thanks for the heads-up.


#6

My LO just refreshed…I had a document open and the Ubuntu Dock seems to think it’s no longer open even though it is (no orange pip)

Also when I tried to open that file it said I had it open and it was ‘locked for editing’, rather than just refocusing on the window I have open.

I then got this error when trying to close/save the file:

saving the document file:///home/adam/snap/libreoffice/43/.config/libreoffice/4/user/basic/script.xlc:
General Error.
General input/output error.

and then, after clicking OK, another error window which unfortunately I didn’t capture :frowning:

Presumably this is because the instance I have open is revision 43 and the new one is 44 that Ubuntu Dock is trying to launch from, but LO should ‘just work’ on refreshes. Given refreshes are effectively silent, ordinary users will be confused as to what’s going on here. How could the experience be made better? How can the system recognize that revision 43 is the one that’s open and therefore not try and launch revision 44 whilst revision 43 is open?

$ snap changes
ID   Status  Spawn                 Ready                 Summary
245  Done    2017-12-04T10:46:38Z  2017-12-04T10:47:03Z  Auto-refresh snap "libreoffice"
$ snap info libreoffice
tracking:    candidate
installed:   5.4.3.2 (44) 431MB -
refreshed:   2017-12-01 20:41:15 +0000 UTC
$ snap info core
tracking:    candidate
installed:   16-2.29.4 (3517) 87MB core
refreshed:   2017-11-20 04:21:00 +0000 UTC
$ snap version
snap    2.29.4
snapd   2.29.4
series  16
ubuntu  17.10
kernel  4.13.0-17-generic

#7

That looks like a more general issue with the desktop not being aware that a running snap has been updated under its feet. I think it’s been already mentioned to me about the chromium snap, too.
I have filed bug #1736525 to track and investigate the issue.


#8

Thanks for the feedback everyone. Libreoffice 5.4.3 has now been promoted to the stable channel.