Call for testing: GIMP

GIMP is now available for testing in the beta channel.

install with:
sudo snap install --beta gimp

There is an issue that I’ve seen where the file chooser does not list the home directory as a “place” in the left-hand menu. I can’t work out whether this is a problem with how I’ve built the package or not, yet.

7 Likes

Is your snapcraft.yaml available somewhere online? Having a look to it
could make easier to have an idea about what the file chooser issue
could be.

yes, the snap is over at https://github.com/diddledan/gimp-snap

2 Likes

Tried it, did some editing work and everything that I needed seemed to work fine!

Gave this a quick test, it works, but I have a few observations :slight_smile:

No stage-packages:

You’ve defined the build-packages: but not the stage-packages:. While snapcraft will try and bundle relevant .so files pulled in via build-packages: it is not perfect and also not magical​:sparkles: :tophat:

You should make sure all the runtime requirements are satisfied by listing them in stage-packages:

No theme integration

I can see you’re using the desktop-gtk2 helper but there is no theme integration. Possibly due to no stage-packages: mentioned above.

Python is required

Looks like you need to bundle Python in stage-packages: too because I see lots of warnings. I’m guessing some plugins won’t function. Also due to no stage-packages: mentioned above.

GIMP-Warning: Bad interpreter referenced in interpreter file /snap/gimp/5/usr/lib/gimp/2.0/interpreters/pygimp.interp: /usr/bin/python
(gimp:27962): LibGimpBase-WARNING **: gimp: gimp_wire_read(): error
/usr/bin/env: ‘python’: No such file or directory

Seems to basically work here as well, thanks!

Also seeing the Python errors @Wimpress mentioned above, though.

Thank you thank you thank you thank you, installing now.
This is an everyday tool for me, so I’ll have an extensive workout for it.
Really hope you can get GEGL and 2.10 working, that’s what I really need.

Immediate reactions: Godlike package.
self-configuring color management is going to be a bit weird, usually I keep my monitor profiles in a hidden directory (easy fix, make them unhidden - loading it appears to work I’ll test again soon when I have more time) but I have no idea how things work with org.gnome.whatever system stuff, and whether snaps will automatically be able to figure all that out.

as Martin says, python is a definite must, however that works with the snap-dependency system.

Just ran into a system-stalling bug with a GEGL op:

(gimp:1836): GEGL-WARNING **: Failed to set operation type gegl:mosaic, using a passthrough op instead

(gimp:1836): GEGL-WARNING **: Failed to set operation type gegl:bump-map, using a passthrough op instead
Missing fast-path babl conversion detected, Implementing missing babl fast paths
accelerates GEGL, GIMP and other software using babl, warnings are printed on
first occurance of formats used where a conversion has to be synthesized
programmatically by babl based on format description

*WARNING*: missing babl fast path(s) between formats "RaGaBaA float" and "CIE LCH(ab) float"
./usr/bin/gimp: terminated: Terminated

Not sure if this is a problem native to 3.8.20 (as I’ve used 2.10.git for years now).

I tried getting the edge version snapped last year (I think?) with the guy that runs the famous ppa. I can’t find his (admittedly super-strange) approach to getting a semi-working build, might not be publicly available. If you hadn’t seen it, here was my very unsuccessful attempt at snapping gimp-git:

Don’t have time to keep poking, but I’ll do so later. Thank you again!

2 Likes

Just a stupid question (as I couldn’t find the answer anywhere): @daniel why aren’t you snapping the latest 2.8.x version?

Thanks again for this!

@pachulo, good question. the answer is I used a snapcraft.yml that someone had already put work into and I wanted to get it actually working before I updated it to the most recent revision

2.8.22 is now in the beta channel and also includes working python script support

4 Likes

Had a quick test. Things are definitely improved in terms of providing the required runtime requirement. I’m puzzled why there is no desktop theme integration, you are using the desktop-gtk2 helper. @didrocks @seb128 could you take a look, I’m just stepping on a plane…

Hi everyone, I’m new to .snap’s and arleady like the idea, but not surprisengly got a problem here.

When I run ‘sudo snap install --beta gimp’ I got ‘error: cannot install “gimp”: snap not found’, what’s wrong with the command?

I’m running on Ubuntu 14.04 updated to 17.04 (with errors two times, but it didn’t affect on something) 32bit with GnomeDE installed. Tried to run ‘sudo apt-get install snapd’/‘sudo apt-get install snap’/‘sudo apt-get install snapcraft’ - no changes.

AFAIK snaps only work on 64bit systems (of the pc variety - I think arm works in 32bit mode) :frowning:

Too bad… Don’t you know, 32bit mode planned as a feature?

I believe it’s been decided to not put it on the roadmap.

What makes you say that? You can build for x86-32 and upload it to the store.

2 Likes

snaps support:

  • i386
  • amd64
  • armhf
  • arm64
  • s390x
  • ppc64el

pretty much since the start in 15.04 …

2 Likes

my thinking was based on the premise that the autobuilder doesn’t offer an option to build for i386…?

you mean build.snapcraft.io ? yes, thats true,

you can use launchpad directly though (with a mirrored GH tree), that offers all of them