Call for testing: Flare - an open source 2D RPG


#1

As the weekend is upon us, it is probably time for another bit of gaming fun. This time I’ve snapped http://flarerpg.org/ - a free 2D action RPG in a similar style to the early Diablo games.

To install:
sudo snap install flare-rpg

Due to a bug which is fixed upstream, audio will not work until you manually type:
sudo snap connect flare-rpg:process-control

Please try this on your machine, and let me know if it works on your particular hardware. I’m keen to know about your graphics card/drivers etc.

Cheers and enjoy!


Snap wishlist - suggestions wanted!
#2

Thanks so much for doing this.
Worked here on my Intel based 16.04 KDE Neon machine.


#3

You mean this is fixed in their master or something? :slight_smile: Could we have master as an edge build maybe?


#4

It’s a snapd bug, which is fixed and will trickle down to us eventually.


#5

yay! thanks! i don’t haz to compile the game anymore X-) . seems to work on 16.04 intel


#6

:frowning: didn’t work for me…

➜ ~ flare-rpg
INFO: Custom data path: "/snap/flare-rpg/8/"
INFO: Flare 1.0 (Linux)
*** stack smashing detected ***: /snap/flare-rpg/8/usr/games/flare terminated
[1] 26940 abort (core dumped) flare-rpg

➜ ~ snap version
snap 2.31.2-1
snapd 2.31.2-1
series 16
arch
kernel 4.15.9-1-ARCH


#7

That sounds unpleasant. I haven’t a clue how to start debugging that. Do other snaps run well on your machine?


#8

Not every snap, chromium (no H/W Acceleration)… PPSSPP didn’t work same stack error, VLC also didn’t work for me…

 ➜  ~ screenfetch
                   -`                 
                  .o+`                 syntist@Syntist-PC
                 `ooo/                 OS: Arch Linux 
                `+oooo:                Kernel: x86_64 Linux 4.15.9-1-ARCH
               `+oooooo:               Uptime: 1h 12m
               -+oooooo+:              Packages: 796
             `/:-:++oooo+:             Shell: zsh 5.4.2
            `/++++/+++++++:            Resolution: 1920x1080
           `/++++++++++++++:           DE: GNOME 
          `/+++ooooooooooooo/`         WM: GNOME Shell
         ./ooosssso++osssssso+`        WM Theme: Adapta
        .oossssso-````/ossssss+`       GTK Theme: Adapta [GTK2/3]
       -osssssso.      :ssssssso.      Icon Theme: Papirus-Adapta
      :osssssss/        osssso+++.     Font: Ubuntu 11
     /ossssssss/        +ssssooo/-     CPU: Intel Core i5-3570 @ 4x 3.8GHz [27.8°C]
   `/ossssso+/:-        -:/+osssso+-   GPU: GeForce GT 640
  `+sso+:-`                 `.-/+oso:  RAM: 3478MiB / 11956MiB
 `++:.                           `-/+/
 .`                                 `/

#9

Interesting. Do you have a file called ~/snap/flare-rpg/current/.config/flare/settings.txt? If so, can you try changing hwsurface to 0?


#10

Nope :frowning:


#11

Can you try starting up with this file: https://ovh.themcphails.uk/index.php/s/C3sj69cKECKdBqF


#12

Ubuntu 18.04 with Intel® HD Graphics 620 (Kaby Lake GT2)
FPS pretty low, but playable.
An issue when i enable “hardware surfaces” in settings:

snap core
installed: 16-2.32~pre4+git612.2003af8 (4259)

snap flare-rpg
installed: 1.0 (8) 179MB -


#13

No luck, after that the window appear i did continue and the same output…

➜  ~ flare-rpg
INFO: Custom data path: "/snap/flare-rpg/8/"
INFO: Flare 1.0 (Linux)
*** stack smashing detected ***: /snap/flare-rpg/8/usr/games/flare terminated
[1]    29437 abort (core dumped)  flare-rpg

#14

You can try beta/edge version of core, i had issue with spotify on stable.

snap refresh core --channel=beta
or
snap refresh core --channel=edge

and retest if game will run


#15

No luck tried both channel


#16

Do any of the other SDL games I have in the store work for you (boa or talesofmajeyal)?


#17

@zyga may know what to do since this is snappy on Arch?


#18

Hmm, same stack problem :frowning:

➜ ~ boa
GZDoom g3.2.3-79-gafa5b28 - 2017-12-10 16:27:36 +0000 - SDL version
Compiled on Feb 15 2018

M_LoadDefaults: Load system defaults.
W_Init: Init WADfiles.
adding gzdoom.pk3, 671 lumps
adding zd_extra.pk3, 122 lumps
adding /snap/boa/134/wolf_boa.pk3, 14294 lumps
I_Init: Setting up machine state.
CPU Vendor ID: GenuineIntel
Name: Intel® Core™ i5-3570 CPU @ 3.40GHz
Family 6, Model 58, Stepping 9
Features: SSE2 SSE3 SSSE3 SSE4.1 SSE4.2
I_InitSound: Initializing OpenAL
AL lib: (WW) ReadALConfig: Ignoring XDG config dir:
Opened device Built-in Audio Analog Stereo
EFX enabled
V_Init: allocate screen.
S_Init: Setting up sound.
ST_Init: Init startup screen.
Checking cmd-line parameters…
S_InitData: Load sound definitions.
G_ParseMapInfo: Load map definitions.
Texman.Init: Init texture manager.
ParseTeamInfo: Load team definitions.
LoadActors: Load actor definitions.
script parsing took 570.38 ms
R_Init: Init Doom refresh subsystem.
DecalLibrary: Load decals.
M_Init: Init menus.
P_Init: Init Playloop state.
ParseSBarInfo: Loading custom status bar definition.
a Realm667 project
D_CheckNetGame: Checking network game status.
player 1 of 1 (1 nodes)
*** stack smashing detected ***: /snap/boa/134/bin/gzdoom terminated
/snap/boa/134/launcher: line 83: 3531 Aborted (core dumped) ${SNAP}/bin/gzdoom -iwad ${SNAP}/wolf_boa.pk3 -config ${GAMEDIR}/boa.conf -savedir ${GAMEDIR}


#19

OK, so it looks like it might be an issue with snaps on your distro. I’m afraid I’m not clever enough to be able to guide you on how to fix this.


#20

Thanks for the help though :slight_smile: