Call for testing: Android Studio


#1

Android Studio is now available as a snap in the candidate channel

install with
sudo snap install android-studio --classic --candidate

I haven’t found any issues yet but if anyone finds it, please feel free to either report here or at https://github.com/snapcrafters/android-studio/issues

Expect more announcements for other development tools.


#2

Awesome, I’ve been using Android studio a bit lately, so I will now use the snap one to test it and let you know.


#3

I have opened a project created with Android Studio previously (not the snap one) and modified it and ran it on my phone.
Everything looks fine, found no issues.


#4

Oh, just one thing, even if everything works fine up to now, I can see this message after lauching “android-studio”: Gtk-Message: Failed to load module “overlay-scrollbar”.


#5

I mostly think that message is fine to ignore as Studio does not use them. Did you try to run the non-snap version from commandline as well ?


#6

Yes I used to use it launching it from command line, and now I found out that the same message appears also launching Android Studio from command line, so probably it’s not related to the snap.


#7

@letozaf Launched the ostentatious android-studio from XFCE4-panel, myself.

Lemme see if anyone has anything else other than Angular 2 to share ?


#8

I tried it (on Debian Stretch) and didn’t have any problems. It would be nice to have working installation instructions in the GitHub repo, i had to find this thread first to find the --candidate flag (maybe in the README with an info about the candidate channel)


#9

@popey I think its time to graduate Android Studio to stable.


#10

I’d like to do a quick test on all the VMs I have here if that’s okay with you @om26er - can we push to stable tomorrow, once done?


#11

Sure no problem. I actually have one last change that I am working on right now.


#12

Kindly merge this one so that we can have a fresh package for final release. https://github.com/snapcrafters/android-studio/pull/15


#13

Merged, thanks @om26er


#14

Thanks, published the new build to candidate, this is what we should release.

One thing I noticed is that a single commit to git actually results in two new revisions of the same snap in dashboard.snapcraft.io, in this case revision 29 and 30 were published. I was on revision 28 previously, first I released rev29 to candidate and did a snap refresh android-studio which completed quickly (delta update worked), then I released rev30 to candidate channel and again did a refresh but this time its re-downloading the complete snap.

That’s some odd bug in the infrastructure that I don’t really understand.


#15

By default build will build an amd64, i386 and armhf snap. The armhf builders are down for maintenance, so you’re getting an amd64 and i386 build. One revision will be the 64-bit build, the other will be the i386 build. We currently don’t have a way to force build.snapcraft.io to only build one arch, but I believe that’s on the roadmap.


#16

That’s odd behavior ? If I am on 64bit arch then why is my system pulling both 64bit and 32bit revision.


#17

Interestingly, this snap says it supports both amd64 and i386 architectures. Probably because it contains some amd64 and some i386 binaries.


#18

As suspected, this is broken. It works on amd64 perfectly, but if you install it on an i386 system, it’s broken.

I suspect we may need the architectures: [amd64] stanza ? Or some other way to make it not build a mixed snap. Not quite sure how we do that with build.snapcraft.io - perhaps @cjwatson know the magic?

I’ve never seen a snap which has the same revision in both architectures before.

 # snapcraft status android-studio
Track    Arch    Channel    Version    Revision
latest   amd64   stable     -          -
                 candidate  3.0.1.0    27
                 beta       3.0.1.0    27
                 edge       3.0.1.0    27
         i386    stable     -          -
                 candidate  3.0.1.0    27
                 beta       3.0.1.0    27
                 edge       3.0.1.0    27

(or does it just need to ship with both amd64 and i386 jre? That seems a nasty solution).


#19

The architectures stuff is planned but not yet implemented in Launchpad, and in any case it will probably only serve to limit the set of builds that are dispatched. Launchpad isn’t going to be doing anything to explicitly build a multi-architecture snap - it must be something in your package’s build system.

(I don’t believe that revision 27 was built on Launchpad; it seems to have been built manually.)


#20

The build was done by build.snapcraft.io