Call for testing: Android Studio

Android Studio comes with JRE and the tarball they provide is supposed to work on both amd64 and i386 unchanged.

I will download a i386 image now and run Android Studio directly from the source they provide (I believe that will definitely work).

Well … it may have been built by BSI but it wasn’t uploaded to the store by BSI/Launchpad.

print(sorted(build.store_upload_revision for build in lp.load('').completed_builds if build.store_upload_revision))
[16, 17, 18, 19, 20, 21, 22, 23, 24, 26, 29, 30]

So I just tried Ubuntu 16.04 i386 in a VM and I get the exact same error from non-snap install as well. So It seems Google only cares about 64bit users so only ships 64bit JRE with source.

Shall we only support Android Studio on 64bit machines for now ?

The updated snap only builds for 64bit installs, so the above issue won’t happen.

I have installed android studio from snap on different distro over the past few month and so far so good. Lets move this to stable now (revision 34 that is).

1 Like

Done! Thanks!

yesterday version 3.1 has come out
Can you update it?

1 Like

I have version (35) on Ubuntu 17.10, amd64 but I can’t launch any AVD. Whichever device configuration I choose, any attempt to start the emulator just gives:

11:03 AM Executing tasks: [:app:assembleDebug]

11:03 AM Emulator: libGL error: unable to load driver:

11:03 AM Emulator: libGL error: driver pointer missing

11:03 AM Emulator: libGL error: failed to load driver: i965

11:03 AM Emulator: libGL error: unable to load driver:

11:03 AM Emulator: libGL error: failed to load driver: swrast

11:03 AM Emulator: X Error of failed request: BadValue (integer parameter out of range for operation)

11:03 AM Emulator: Major opcode of failed request: 152 (GLX)

11:03 AM Emulator: Minor opcode of failed request: 24 (X_GLXCreateNewContext)

11:03 AM Emulator: Value in failed request: 0x0

11:03 AM Emulator: Serial number of failed request: 56

11:03 AM Emulator: Current serial number in output stream: 57

11:03 AM Emulator: Process finished with exit code 1

1 Like

Seems similar to this topic?

I don’t know. Android Studio uses classic confinement so it shouldn’t have any OpenGL restrictions?

1 Like

No, not really. Its a known issue with Android Studio and linux, please try to export ANDROID_EMULATOR_USE_SYSTEM_LIBS=1 in your environment and that should fix it.

Try in a terminal


If that fixes it, you need to add that variable to a more permanent place.

More reading here:

1 Like

Yes, this does the trick. Thank you so much for the solution.
IMO the snap package should be updated to include this in its launch script.

1 Like

Today I installed this on my fresh 18.04 install and I got from zero to having an app in the review queue on Google Play in under 5 hours. Everything just worked. The only problem was the emulator crash described above, but I could just test on real hardware. Excellent stuff. I’m also enjoying the intellij and pycharm snaps. :slight_smile:


Where is ANDROID_HOME for the snap?

1 Like