Autoconnection of camera for wickrpro

We currently need to have camera access to allow for video conferencing within the app. It’s becoming increasingly difficult to explain to our customers that they need to manually run a command to get the camera to work. Any way we can get an automatic connection of the camera?

@tleavy - does wickrpro correspond to this application: ?

+1 with reviewer hat :tophat: predicated on @jdstrand’s assumption being correct - anyone installing wickr knowingly is probably aware of, and happy with it having access to the camera (which is no different from installing a non-snap). Snaps allow a privacy-conscious user to then disconnect the interface, but I think it’s reasonable and expected for this to work out of the box.

A really privacy-conscious user will also have a piece of tape over the camera anyway :slight_smile:

  • Daniel

@jdstrand It does. The snap is officially supported by us and we are pushing all Linux users in this direction. We actually have 2 snaps. One for Wickr Me, and another for Wickr Pro. Wickr Me is anonymous and typically not used for video, whereas pro is. Unless someone complains we can leave Wickr Me as opt in for camera

Thanks for the additional information. The camera is a core proposition for this communication application. +1 to auto-connect camera.

2 votes for, 0 against for auto-connecting camera. Granting auto-connect. This is now live.

Thanks all, love the work you guys are doing. It’s helped us reach users and saves us a lot of time and energy


@tleavy please reach back. Using Arch Linux and Wickrpro won’t launch with errors:

Gtk-Message: 17:32:34.097: Failed to load module “canberra-gtk-module”
0529/173346.318854:WARNING:resource_bundle_qt.cpp(116)] locale_file_path.empty() for locale
Qt WebEngine ICU data not found at /opt/qt512/resources. Trying parent directory…
Qt WebEngine ICU data not found at /opt/qt512. Trying application directory…
Installed Qt WebEngine locales directory not found at location /opt/qt512/translations/qtwebengine_locales. Trying application directory…
Qt WebEngine locales directory not found at location /snap/wickrpro/398/usr/bin/qtwebengine_locales. Trying fallback directory… Translations MAY NOT not be correct.
Path override failed for key ui::DIR_LOCALES and path ‘/home/nmbabb/snap/wickrpro/398/.QtWebEngineProcess’
Qt WebEngine resources not found at /opt/qt512/resources. Trying parent directory…
Qt WebEngine resources not found at /opt/qt512. Trying application directory…
[0529/173346.346041:WARNING:resource_bundle_qt.cpp(116)] locale_file_path.empty() for locale
Fontconfig warning: FcPattern object weight does not accept value [40 210)
Segmentation fault (core dumped)

Everything is there, Canberra, QTWebEngine, etc.

I can’t find any other way to get to you. Sorry!

looks like another fontconfig incompatibility:

as a workaround you can:

sudo rm /var/cache/fontconfig/*
rm ~/.cache/fontconfig/*
fc-cache -r

Hi @ogra . Gave it a shot, but no joy. One thing I’ve noticed (but am not qualified to diagnose) is that the QTWebengine resources it looks for don’t seem to be installed in the snap directory for wickrpro. (Without proper knowledge) it makes me wonder if wickr isn’t installing everything it needs, and then thinks it will fall back to a QT version installed system wide, BUT the newer QT installs don’t match anything wickr wants either. I’m hoping @tleavy can jump in here too to fill in the gap on my wild speculation. :slight_smile:

Given that, I’ll happily try other suggestions you have if any of this made sense.



Adding to this. I know you’re on to something with fonts because the Snap Store fonts aren’t working either. Just empty rectangles. The workaround doesn’t help that either so it’s like the workaround “used” to help, but even that doesn’t fix it anymore. Magical world of updates breaking something else I guess.

Hey guys, thanks for bringing this to my attention. We have had users resolve this with the font workaround before. We did recently change the snap to rely on QT 5.12 installed from a Ubuntu 18.04 PPA, maybe that’s the issue. Will create a ticket internally to see what’s up.

what version of Arch linux are you on and what version of WickrPro is installed?

Edit: I updated arch and WickrMe to 5.55.6 and I had the same error with fontconfig and the crash. I tried:

sudo rm /var/cache/fontconfig/*
rm ~/.cache/fontconfig/*

and it worked. after that I could run WickrMe. WickrPro would be the same. Just want to confirm you ran those steps. Thanks

Hi spomp,

Using GUI “about”, lsb_release -a, or reading the /etc/os-release file all come back with Arch Linux Release=Rolling.

I can confirm it is current on patches and updates.

Wickrpro is 5.55.6 (398) latest stable

Gnome version 3.36.2


Thanks. and you tried this again?

sudo rm /var/cache/fontconfig/*
rm ~/.cache/fontconfig/*

I’ve executed the font commands without any success. I don’t get fonts on the snap store either. Just empty boxes. It’s a font issue, but I’m not getting the success others get with removing the font configs.

Holy crap! I did it again for the umpteenth time and it’s working now. Swear to God I executed those commands and updated till I thought I’d lose my mind with no success. Time for me to sit on the floor rocking and muttering incoherently for awhile I guess. :slight_smile:

Thanks for the nudge!

No problem. sorry it happened. I’m not sure if it’s an issue with arch or snapcraft but this workaround seems to be common for other apps that use snapcraft.