Autoconnect 'office20' and 'abstractgames' to kde-frameworks-5-core18

We have created two apps, O20 (https://snapcraft.io/office20) and the Abstract Games Suite (https://snapcraft.io/abstractgames), and are losing customers and receiving bad reviews complaining that our apps do not launch, because they are not following the terminal instructions to connect to the kf5 content snap.

Could @reviewers review this?

(Sorry, this is our first time in this forum…)

This is possible, isn’t it? I know that there is already a thread open for this (Kde-neon autoconnect), but it said that you could ask to autoconnect your app:

I’m sorry if there is something I’m not understanding correctly…

I’m +1 on granting auto-connect to the content snap in question (that’s the main point of content snaps, right?). BTW the content snap is kde-frameworks-5-core18 (content name kde-frameworks-5-core18-all).

  • Daniel

Thank you @roadmr. Can the other @reviewers review this, plz?

Ping, anybody? @ogra or @jdstrand perhaps?

not a reviewer, sorry …

Oh, sorry. I wasn’t quite sure who the reviewers are…

-1 to auto-connect. Please see my justification for this in Autoconnect ksnip to kde-frameworks-5-core18

@reviewers - please note, auto-connecting the content interface between arbitrary publishers is not typically allowed. Please see Process for aliases, auto-connections and tracks (“auto-connection request considerations”). For those that have voted in the affirmative, please justify why you feel this request is unique and should be auto-connected.

@abstractdevelop - please see Autoconnect ksnip to kde-frameworks-5-core18 for paths forward. It might be that kde decides to pursue global auto-connection, but if not, there are paths forward for you as well.

OK thank you @jdstrand for clarifying. I understand your reasons, and thank you for trying to protect the publishers of the snap from instability. :frowning_face:
Maybe the snapcraft people can make a global snap which everybody can autoconnect to like the gnome one, then they can ensure that none of the snaps break, but still make it easier for people to deliver snaps which require the latest version of Qt.

Note: I talked to @jriddell on Matrix and he said he’ll request auto-connection for the kde-frameworks-5-core18 snap tomorrow, so that should solve the issue of your snaps and every other snap using this content snap.

2 Likes

Thank you @galgalesh! That is very good news! :smiley:

1 Like

I’ll change my vote to +0 then (i.e. “that’s not the way to do it, sorry”). I did miss the fact that cross-publisher autoconnects are not usual and that it depends heavily on the provider guaranteeing a stable “interface”.

  • Daniel