Access to NAS drive


#11

A workaround is to probably mount the NAS drive under the /media directory manually in order to allow the snap to access it. For example: mount - How to map a network drive? - Ask Ubuntu.


#12

When you say ‘actual snap name’, where do I find that, as all the names showing up in snap list do not work with the sudo snap command


#13

It should be listed in the Name column of the output of the snap list command

What is the exact error message? Also it would be helpful if we focus on a certain snap that you’ve encountered this problem.


#14

error: snap “snap_name” (whichever) has no plug named “removable-media”


#15

This indicates that the snap doesn’t assert the removable-media interface, you have to contact its maintainer to assert it and push a new build that enables the interface.


#16

Please explain ‘assert the removable-media interface’, you are dealing with a total dullard here


#17

This means that the maintainer(packager) has to enumerate the interface in the build recipe of this particular snap. Unfortunately this isn’t something that can be done by the end user.


#18

Sorry, but I do not understand any of that, can you please explain plain English
Are you saying I need to speak to Western Digital with regard to this, for if so I can see my use of Ubuntu soon coming to an end, as WD are not going to be that interested in linux solutions at this point in time


#19

Nope, you’ll have to speak with the person that publish the particular snap you’re using in order to solve this, the contact information may be available in the Snap Store.


#20

The snap being used was downloaded with Ubuntu 18.04, so does this mean they have included this without thought of the effects on users with NAS drives?
I am starting to feel rather negative if this is the case, as I walked away from Windows because of what I perceived to be a total lack of consideration for the end user


#21

Which snap in particular you’re talking about? The network mount is a relatively minor usecase that might not being worked on as of now, please give the developers a bit more time to resolve this issue.


#22

I am sorry, but it is not a minor user case for mewhen it stops me working. New methodology should only be implemented once it can be used as previously
I regularly use LibreOffice, but now find it unsuitable due to reading and writing to the NAS drive
I have just read that LibreOffice can be removed and reinstalled in Debian format,which rather defeats the object and of course, how much longer will this be possible?
I have quickly become one massive disillusioned user


#23

I’m afraid this is not the case for snaps to be the least.

As far as I can tell Ubuntu 18.04 do ship the Debian format Libreoffice by default, also you may use the LibreOffice Fresh PPA if you require recent releases.


#24

Mine loaded with a Snaps version, which I now intend to bin and use the Debian version, but should the situation occur that it is Snaps or nothing, then unless there is a massive seed change, then Ubuntu will be binned as well


#25

I had the same problem with keepassxc snap. The snap can not access the path of my other hard disc for storage which is mounted at /media/data

The solution is to install the snap in classic mode:
snap install --classic keepassxc

This allows the snap to access all system files. Until the snap developers create the required interface installing with --classic mode is the only solution i can see.

(An interface consists of a connection between a slot and a plug. The slot is the provider of the interface while the plug is the consumer, and a slot can support multiple plug connections.) Interface management


#26

… but the libreoffice snap does have the removable-media slot.

In gnome software, you can search for libreoffice, click it, click Permissions, and in there make sure Read/write files on removable storage devices is checked.
Like so:


#27

Connect the snap to the removable-media interface and you’re good to go, no need to install the snap in --classic mode. Note that strictly confined snaps does not guarantee it will run properly in classic confinement as well.


#28

jonathon@KDE-DiningR:~$ snap interfaces keepassxc

Slot Plug
:desktop-legacy brave,cumulonimbus,eog,keepassxc,opera
:gsettings brave,cumulonimbus,eog,keepassxc,opera,spotify
:home brave,cumulonimbus,eog,keepassxc,opera,spotify
:network brave,cumulonimbus,eog,keepassxc,opera,spotify
:network-bind keepassxc
:opengl brave,cumulonimbus,keepassxc,opera,spotify
:unity7 brave,cumulonimbus,eog,keepassxc,opera,spotify
:wayland brave,cumulonimbus,eog,keepassxc,spotify
:x11 cumulonimbus,keepassxc,opera,spotify

  • keepassxc:raw-usb
  • keepassxc:removable-media

Example:
$ snap connect snap:plug-interface snap:slot-interface

jonathon@KDE-DiningR:~$ snap connect keepassxc:removable-media :keepassxc
error: snap “core” has no slot named “keepassxc”

The slot column is empty or it has nothing assigned. Any suggestions?


#29

You are connecting from the keepassxc snap’s removable-media plug to the core snap’s removable-media slot, so the proper command is:

  • snap connect keepassxc:removable-media core:removable-media

as the target snap is the core snap it can be abbreviated to:

  • snap connect keepassxc:removable-media :removable-media
  • snap connect keepassxc:removable-media

#30

Command worked thanks