Access to NAS drive

Which snap in particular you’re talking about? The network mount is a relatively minor usecase that might not being worked on as of now, please give the developers a bit more time to resolve this issue.

I am sorry, but it is not a minor user case for mewhen it stops me working. New methodology should only be implemented once it can be used as previously
I regularly use LibreOffice, but now find it unsuitable due to reading and writing to the NAS drive
I have just read that LibreOffice can be removed and reinstalled in Debian format,which rather defeats the object and of course, how much longer will this be possible?
I have quickly become one massive disillusioned user

I’m afraid this is not the case for snaps to be the least.

As far as I can tell Ubuntu 18.04 do ship the Debian format Libreoffice by default, also you may use the LibreOffice Fresh PPA if you require recent releases.

Mine loaded with a Snaps version, which I now intend to bin and use the Debian version, but should the situation occur that it is Snaps or nothing, then unless there is a massive seed change, then Ubuntu will be binned as well

I had the same problem with keepassxc snap. The snap can not access the path of my other hard disc for storage which is mounted at /media/data

The solution is to install the snap in classic mode:
snap install --classic keepassxc

This allows the snap to access all system files. Until the snap developers create the required interface installing with --classic mode is the only solution i can see.

(An interface consists of a connection between a slot and a plug. The slot is the provider of the interface while the plug is the consumer, and a slot can support multiple plug connections.) Interface management

… but the libreoffice snap does have the removable-media slot.

In gnome software, you can search for libreoffice, click it, click Permissions, and in there make sure Read/write files on removable storage devices is checked.
Like so:


Connect the snap to the removable-media interface and you’re good to go, no need to install the snap in --classic mode. Note that strictly confined snaps does not guarantee it will run properly in classic confinement as well.

jonathon@KDE-DiningR:~$ snap interfaces keepassxc

Slot Plug
:desktop-legacy brave,cumulonimbus,eog,keepassxc,opera
:gsettings brave,cumulonimbus,eog,keepassxc,opera,spotify
:home brave,cumulonimbus,eog,keepassxc,opera,spotify
:network brave,cumulonimbus,eog,keepassxc,opera,spotify
:network-bind keepassxc
:opengl brave,cumulonimbus,keepassxc,opera,spotify
:unity7 brave,cumulonimbus,eog,keepassxc,opera,spotify
:wayland brave,cumulonimbus,eog,keepassxc,spotify
:x11 cumulonimbus,keepassxc,opera,spotify

  • keepassxc:raw-usb
  • keepassxc:removable-media

$ snap connect snap:plug-interface snap:slot-interface

jonathon@KDE-DiningR:~$ snap connect keepassxc:removable-media :keepassxc
error: snap “core” has no slot named “keepassxc”

The slot column is empty or it has nothing assigned. Any suggestions?

You are connecting from the keepassxc snap’s removable-media plug to the core snap’s removable-media slot, so the proper command is:

  • snap connect keepassxc:removable-media core:removable-media

as the target snap is the core snap it can be abbreviated to:

  • snap connect keepassxc:removable-media :removable-media
  • snap connect keepassxc:removable-media

Command worked thanks