Yaru dark theme toggle review request

Hello reviewers

I forked a gnome shell extension for toggleling between a gtk dark and light theme and made it work for yaru and yaru-dark
Peek%202019-09-10%2018-28

Classic confinement is needed because it is a gnome shell extension for the user.

Please review this snap here: https://dashboard.snapcraft.io/snaps/yaru-dark-theme-toggle/revisions/1/
And let me upload it to the store :slight_smile:

Best regards,
Frederik

1 Like

Sorry for the delay in responding. It is true that classic is currently needed to install a gnome shell extension, but it is possible for snapd to be extended to install gnome extensions. That said, the extension would not be running under confinement since it would be run by gnome-shell in process.

@pedronis - this seems like a candidate for classic, though it is a new use case. Can you comment?

What’s the standard packaging for a gnome-shell extension if there is such a thing?

@frederik-f this request is waiting on your response to @pedronis’s question above.

I think most gnome shell extensions are not packaged at all and availible via extensions.gnome.org

Some are packaged in .deb’s like the ubuntu-dock or the appindicator extension

@marcustomlinson could eventually help out here

Sorry for being rather unhelpful, I normally only contribute with SCSS to ubuntu

@pedronis - historically we’ve not allowed gnome-shell extensions for the reasons outlined. I updated Process for reviewing classic confinement snaps not too long ago to list them in the unsupported category. The requester has provided the requested feedback; please let me know if anything should change.