When I'm using ubuntu-image with --snap, errors appeared

I want to build an image with many snaps so I used (more than 2) --snap option to add snaps. Soon I got a error message. It say something like version not found. So I used --snap (name)=latest/stable , but errors still there.
Any advice?
(I’m using json to create my model, but I don’t know what is called ID. Can you tell me?)

Can you paste the output of the ubuntu-image command you ran?

this is the ID of the snap in the store, it should be the same one you can see when running snap info <packagename>.

If you use the --snap command the ID entry in the model will be ignored by ubuntu-image.

excuse me, I can’t find the ID of “pi” and “pi-kernel”? (I’m building an image for raspberry pi)

you have to run the sanp info ... on the actual architecture you are targeting, on a PC the snap info command will only show amd64 snaps (for “snap download” setting the variable UBUNTU_STORE_ARCH=armhf works, sadly that does not seem to be taken into account for “snap find” at all)

here is the output on a Pi installation:

ogra@ubuntu:~$ snap info pi| grep snap-id
snap-id:      YbGa9O3dAXl88YLI6Y1bGG74pwBxZyKg
ogra@ubuntu:~$ snap info pi-kernel| grep snap-id
snap-id:      jeIuP6tfFrvAdic8DMWqHmoaoukAPNbJ
ogra@ubuntu:~$

Thanks for your answer :smiley:

Oh, what is the password? (I configured my server properly and I tried: "ubuntu (SSO account password) 12345678 [blank](just enter without any keys)", but they didn’t work.->Permission denied, please try again.)


There wasn’t anything displaying on my screen except the “core20” text

Ubuntu Core only allows ssh key authentication, passwords are disabled…

this is the main reason why it requires an Ubuntu SSO account, you need to add your ssh key to that account and need to make sure you have the key in your keyring on the host you ssh from …

EDIT: https://login.ubuntu.com/ssh-keys is the place to add them …

I added the ssh keys before this

and you have your pub key locally on the host you ssh from ?

yes

hmm, this looks all correct … and you did also put in the email address of the account in the first start wizard on screen after the device booted ?

yes, it’s a correct email address.

and it is also the adress you used on the terminal of the device you booted with Ubuntu Core when it showed “Press enter to configure” on the screen ?

you also need to be using the username associated with your USO account when sshing to the box. The terminal on your Core device should indicate both the username associated with your account to login as, and the address the device has on your network.

The screen on device showed: To login: ssh username@192.168.xx.yy and I used this cpmmand. It showed the password screen.