What is the Snap store's bandwith?

Is this forum on Fastly too? I can’t seem to upload a 160kB screenshot :open_mouth:

I’ve uploaded it to drive then so here’s the link: https://drive.google.com/file/d/1bLBYiSkuPOZMGF1Ffy3j3yefokEz73Ay/view?usp=sharing

edit: I’ve tried with all the ad blockers turned off too. It won’t upload.

well, according to that data fastly thinks you can get ~7MBit/s in your downstream …

alan@robot:~$ snap install libreoffice
Download snap "libreoffice" (205) from channel "stable"   22% 10.0MB/s 51.0s

Seems okay for me, here.

@ogra I see that, but I don’t get that speed. Anything else I can try?

@popey I tried refreshing LO to edge channel and got ~450kB/s download speed up until 3% when it dropped to ~180kB/s and is dropping still.

I’ll try a different machine and restarting the current one.

I’m not sure if the store still uses fastly, ISTR that Canonical’s own servers are used for the content caching…

Also look at this thread Extremely slow snap downloads

Ok, weird. It seems to be my machine. I’ve tried installing libreoffice from my laptop and I got ~4MB/s down.

I’ve now switched on my desktop from wired connection to WiFi and I get ~750kB/s down and rising.

the only thing that I can think of is that on the problematic (desktop) machine I’m running the GA kernel on Ubuntu 20.04 as opposed to HWE kernel that Ubuntu now defaulted for 20.04 which I’m running on my laptop.

Although I know it’s anecdotal data at best, fwiw I have been having issues with download speeds from the CDN’s the past few days.

In some cases, the download literally will not start, other times, it will only get 1mbps on a connection that is capable of getting 220mbps download.

It legitimately faster for me to hit control-c and keep retrying the download until it hits an end point that saturates the connection, unless it’s in snapcraft itself, where the slower than usual downloads are actually becoming a significant portion of build time for me locally (I.E, downloading core20/gnome-extensions in the LXD container).

Again, I know it’s anecdotal, but I do think there’s something widespread.
(Using Virgin Media in the UK)


Ok, this is a bit odd.

When I was using a wired connection this was the fastly-debug result: Fastly Debug App

And with the ~7mbps I could only get a snap to download at arround 100kB/s speed.

Now that I’ve switched to WiFi (my mobo has the adapter built in) I get around 1.6mbps speed from fastly-debug: Screenshot_2021-03-12 Fastly Debug App(1)

But android-studio snap is downloading at 1MB/s speed. In fact, it just finished downloading :open_mouth:

edit: and I can now upload images to forum.

Going back to wired connection considerably slows down to download speed. It starts at ~450kB/s and stabilizes at around ~100kB/s.

The thing is, when I use WiFi connection, everything else is slower because the signal is pretty weak but snaps are downloading much faster.

On the wired connection I get much higher speeds at everything else except downloading snaps.

I’m glad to report I no longer have the issue.

The power management was on. Idk why it affected the wired speed too but it did.
I edited /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf and changed the number from 3 to 2 to disable it.

1 Like

I always get it 150kb/s down
But if I cancel the download ( Ctrl + C ) and redownload the snap many times, I get full speed 20+ MB/s


test snapcraft speed https://youtu.be/0RRihoXOeoo

Post a screenshot of the results that you get from http://www.fastly-debug.com/


This is not necessary or useful - the snap store stopped using Fastly last year.

This post (Slow snap store downloads, and slow SSO interactions - RESOLVED) contains more up-to-date information on how to test download speed from the store’s current CDN endpoints. Trace route to those host names would also be helpful.


Oh, sorry. I wasn’t aware of that.

Me too, apologies…

Any chance maintaining it under some post under #doc ? The only documentation I found related is Network requirements.

I have been seeing slow downloads since the last few years. It seems speeds don’t go past 100kb/s, sometimes I can get better speeds by just cancelling a slow snap install and running the command again.