Warning/error creating thread when running snap find

I was playing around with snap find and I noticed that it spewed out an error. I cannot reproduce this.

⟫ snap find --section=database runtime/cgo: pthread_create failed: Resource temporarily unavailable Name Version Developer Notes Summary cassandra 3.7 snapcrafters - Cassandra distributed database mongo32 3.2.7 niemeyer - MongoDB document-oriented database redis-noise 3.2.3 noise - Redis server etcd 3.1.8 tvansteenburgh - Resilient key-value store by CoreOS


This is a know issue around kernel/go bugs. We tried to work around it by introducing changes to the golang compiler and to the kernel (fixing bugs in both places). If you still see the problem it may be because you are on a distribution that does not benefit from either of those yet. Can you please add the output of snap version here?

snap 2.26.9 snapd 2.26.9 series 16 ubuntu 17.04 kernel 4.10.0-26-generic

You most certainly can reproduce it! It just takes a little while. Also, it’s nasty but harmless (a thread that was about to get killed by exec tried to start a new thread).

It’s been addressed in go 1.8, and the fix for that has been backported to 1.6 by @mwhudson and you have it in xenial as of 1.6.2-0ubuntu5~16.04.1. I think 2.26.9 was built earlier than the backport.

There’s another (often comingled) bug that is lp:1672819, which needs a kernel fix (but that’s also done :smiley: ).

The pthread_create thing is also quite possibly not fixed in 17.04. (It will be fine in 17.10 because that has golang-1.8 as the default, which has the fix)