VSCode glibc++6 Needs Update?

Hi All,

I’m running Ubuntu 20.04.

I have been having problems with the Python extension in the VSCode snap. Essentially it wants glibc++6 version GLIBCXX_3.4.22. But the latest version from the snap is:

$ strings /snap/core/current/usr/lib/x86_64-linux-gnu/libstdc++.so.6 | grep GLIBCXX_3.4 | tail -3
GLIBCXX_3.4.19
GLIBCXX_3.4.20
GLIBCXX_3.4.21

… so no matching version here.

My /usr/lib/x86_64-linux-gnu/libstdc++.so.6 has the required version and all the way up to GLIBCXX_3.4.28. I’m not sure, but I think extensions run against the runtime of the snap. Is this correct?

If so, should the snap be updated to work with such extensions?

Thanks,

Matt