vokoscreenNG snap pulseaudio breaks system (linux Mint 18.3) pulseaudio

I LOVE vokoscreenNG! When starting it, I had the big red X under audio and read the fix - installing the snap version of pulseaudio. Certainly this may NOT be your issue, but I’m not sure where else to put it. Anyway, on to the issue. Once I installed the snap pulseaudio, I immediately lost system pulseaudio - though it worked great for vokoscreen. I went through the common process of purging pulseaudio and re-installing it and that worked. I was able to use both by doing this temporary workaround - system pulseaudio worked but so did Vokoscreen - I think.

However, I soon found on every reboot, I had to do similar workarounds to get both to work. Finally I took out the snap pulseaudio, purged the system’s pulseaudio, re-installed it and rebooted. Problem solved … except now vokoscreenNG has NO audio. So not a real fix. Any solution, workaround, fix so I can have both awesome programs working?

NB: I posted this to the vokoscreenNG on the github too. Sorry, not sure how to ask for this fix. Hoping that putting in both places at least one of them will work. Thanks!

I ended up poking around on the mint forum, which gave me an
idea. The workaround (I’m sure there’s a better solution) so far is to
simply put “pulseaudio -D” in the xfce startup group. So far, seems to
solve the problem - this way I get to use the great vokoscreenNG app AND the system’s pulseaudio works like normal too. Lovely!