Vlc doesn't match system theme


#1

I have a dark theme for my desktop, but when i install/run the VLC snap, it shows up in a bright white theme. How can i get it to match my system’s theme? thanks


#2

Could you provide a bit more information? What theme in particular are you using?


#3

it’s called Elementary Dark


#4

Is that independent of the dark variant of the Elementary theme? We have the Elementary GTK and icon themes available through gtk-common-themes. The GTK 3 theme includes a dark variant, but doesn’t install it as an independent theme.

If you are forcing the dark theme via the ~/.config/gtk-3.0/settings.ini file, I don’t think this is visible within the snap application sandbox.


#5

I’m not real sure, it’s been the theme for years.
so i could try snap install gtk-common-themes?

I do have this in the ~/.config/gtk-3.0/settings.ini:
[Settings]
gtk-application-prefer-dark-theme=1


#6

VLC doesn’t even use Yaru or Yaru-dark, both provided by gtk-common-themes. So I think the problem is independent of the particular GTK theme.


#7

I installed gtk-common-themes but didn’t change anything, unless there is some extra configuration needed somewhere? If I use the VLC in the Ubuntu software store then it shows up in a matching dark theme, but it is old and outdated which is why i wanna use the snap version.