Visual Studio Code Snap issue on Manjaro

Visual Studio Code is not opening also any other app not working which uses appmenu-gtk-module. I’ve already installed it.

❯ pacman -Ss appmenu-gtk-module
community/appmenu-gtk-module 0.7.3-1 [installed]

Here is the logs of vscode.

❯ snap run code --verbose
Gtk-Message: 19:37:28.004: Failed to load module "canberra-gtk-module"
Gtk-Message: 19:37:28.005: Failed to load module "appmenu-gtk-module"
/var/lib/snapd/snap/code/35/usr/share/code/../../lib/x86_64-linux-gnu/ version `GNUTLS_3_6_3' not found (required by /usr/lib/gio/modules/
Failed to load module: /usr/lib/gio/modules/
/usr/lib/gio/modules/ undefined symbol: g_task_set_name
Failed to load module: /usr/lib/gio/modules/
/usr/lib/gio/modules/ undefined symbol: g_mount_operation_get_is_tcrypt_system_volume
Failed to load module: /usr/lib/gio/modules/
/snap/core/current/lib/x86_64-linux-gnu/ version `GLIBC_2.25' not found (required by /usr/lib/
Failed to load module: /usr/lib/gio/modules/
/usr/lib/gio/modules/ undefined symbol: g_task_set_name
Failed to load module: /usr/lib/gio/modules/
Gtk-Message: 19:37:28.119: Failed to load module "appmenu-gtk-module"

System Details:-
OS: Manjaro Linux x86_64 20.0.3 Lysia
Host: Aspire ES1-571 V1.06
Kernel: 5.4.44-1-MANJARO

Have you tried the Manjaro forums? Since VSCode is a classic Snap, this doesn’t really have anything to do with Snap since VSCode is trying to find a system library Actually, this is a bug with out the Snap is packaged; Classic Snaps should not be relying on the system having the libs they need.

You are right in that way. I’m also opening this issue on Manjaro forum. Thanks.

You are right. It’s the issue with manjaro itself. I’m missing 2 dependencies:

Dependecies were: libdbusmenu-glib and gconf

Thanks for all your help.

1 Like

well, even classic snaps should be self contained like any other snap, so they should ship everythig they need to run inside the snap, this is clearly a packaging bug in vscode … classic doesnt mean “use random UI libs” since you will not know what API/ABI versions of these libs the distro has …

@suhailmalik you should file an issue at

@ogra it’s solved found same issue and solution on GitHub itself. here is the link for reference. This issue can be closed now. Thanks for all your support and help.

no, it is not solved … a snap must run on all distros without requiring any distro package to run …

this is completely broken packaging and if you check the issue you linked it is just full of people using the same workaround of installing a few distro packages …

@ogra I agree to you for this thing. Tracked down that gconf package which was missing are droppped by vscode team .

1 Like