Update issue with snap, applications having user (default) profiles



snap version
 snap    2.51.4
 snapd   2.51.4
 series  16
 ubuntu  20.04
 kernel  5.4.0-81-generic

Since upgrading Ubuntu and using snap primarily incl. auto-updates, i face a recurring problem on each update of applications like Thunderbird and Remmina for example.
After the update, it looks like the application has been installed from scratch, losing my user’s snap application profile data.
E.g. after Thunderbird snap update, a new default profile exists in ~/snap/thunderbird/common/.thunderbird/ and Remmina is losing all existing connections + saved credentials.

I already tried experimental.refresh-app-awareness for 2 weeks now, but end up with the same problem. I always make sure that the applications are closed before the updates are installed. Doesn’t help though.

Is it a known limitation or issue with snap; or can it be solved?

Thank you for a hint.
Kind regards,

Hi again,

Still re-appearing and good to reproduce on yet another update.
E.g. Remmina with the previous version has had the content in ~/snap/remmina/5025. After the (auto-)update, it’s creating a new directory ~/snap/remmina/5070 from scratch (instead of “porting” the former profile/connections etc. On first start of the updated application, the list of connections is empty.
My current workaround is copying the content from ~/snap/remmina/5025 to ~/snap/remmina/5070. Then the data is available again.
Alternative workaround: revert and stick to an outdated former version.

Since I use 3 applications through snap, Thunderbird, Remmina, Signal and each of them has the problem after updates, I guess, there is something wrong on snap or snap directory… Could there be a mistake in the directory chmod permissions or what else can make snapd to skip the essential step on/after updating?