Unkown font/text issue running different Snap apps

I really have no idea where to post this because I am not sure what the issue is.

I rarely ever use Snap packages, but recently I needed to test something in Firefox and so I installed the Snap version from command line and when I started it it immediately crashed and the window was unreadable square boxes. I thought maybe it was just a Firefox issue, but then I started up the Snap Store (which I don’t think I’ve done before) and it was the same thing! So since this is two applications it seems it’s and actual Snap issue, but it’s not all Snap apps. Gnome System Monitor seems to run fine.

I created a new profile and loaded into its desktop and the Snaps run just fine so I was thinking it might have something to do with my theme so I went back to my profile, disabled all my themes and it still didn’t work.

‘lsb_release -a’

Key Value
Distributor ID: Ubuntu
Description: Ubuntu 20.04.1 LTS
Release: 20.04
Codename: focal

‘uname -a’

Snap --Version

snap    2.46.1+20.04
snapd   2.46.1+20.04
series  16
ubuntu  20.04
kernel  5.4.0-47-generic

Firefox ‘snap list firefox’

firefox 81.0.1-1 432 latest/stable mozilla✓ -

When running Firefox from the command line ‘snap run firefox’ I get:

Gtk-Message: 22:14:14.794: Failed to load module "canberra-gtk-module"
Gtk-Message: 22:14:14.796: Failed to load module "canberra-gtk-module"
Sandbox: /tmp/.X11-unix/X0 is inaccessible (No such file or directory); can't isolate network namespace in content processes
Gtk-Message: 22:14:15.697: Failed to load module "canberra-gtk-module"
Gtk-Message: 22:14:15.699: Failed to load module "canberra-gtk-module"
ExceptionHandler::GenerateDump cloned child 85733
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal...
Exiting due to channel error.
Gtk-Message: 22:14:16.281: Failed to load module "canberra-gtk-module"
Gtk-Message: 22:14:16.283: Failed to load module "canberra-gtk-module"

Snap Store ‘snap list snap-store’

snap-store 3.31.1+git187.84b64e0b 415 latest/stable canonical✓ -

With Snap Store ‘snap run snap-store’ I get:

03:15:26:0240 Gs  failed to create an app for */*/*/*/system/*
03:15:26:0245 Gs  updates-shell: failed to get updates: no plugin could handle get-updates
03:15:26:0246 Gs  failed to create an app for */*/*/*/system/*
03:15:26:0246 Gs  failed to get system app
03:15:26:0246 Gs  Only 0 apps for recent list, hiding
03:15:26:0321 GsPluginSnap Failed to load snap icon: local snap has no icon
03:15:26:0762 Gs  hiding category audio-video featured applications: found only 0 to show, need at least 9
03:15:26:0763 Gs  hiding category productivity featured applications: found only 0 to show, need at least 9
03:15:27:0026 GLib g_variant_new_variant: assertion 'value != NULL' failed
03:15:27:0026 GLib g_variant_new_variant: assertion 'value != NULL' failed
03:15:27:0027 Gs  not GsPlugin error g-io-error-quark:35: Invalid string value converting to GVariant
03:15:27:0027 Gs  not handling error failed for action refine: Invalid string value converting to GVariant
03:15:27:0156 GsPluginSnap Failed to load snap icon: local snap has no icon
03:15:27:0364 GsPluginSnap Failed to load snap icon: local snap has no icon
03:15:27:0610 GsPluginSnap Failed to load snap icon: local snap has no icon
03:15:27:0837 GsPluginSnap Failed to load snap icon: local snap has no icon
03:15:28:0070 GsPluginSnap Failed to load snap icon: local snap has no icon
03:15:29:0115 GsPluginSnap Failed to load snap icon: local snap has no icon
03:15:29:0356 GsPluginSnap Failed to load snap icon: local snap has no icon

Any help would be appreciated and sorry if I am in the wrong place.

See solution on this thread, might work for you too:

2 Likes

That was exactly it… I have had an issue like this before some years ago, just not with Snap… Much appreciated. Fixed.

Solution, thread closed.

Guess my last post got flagged for calling myself a name :frowning:

1 Like