Unexplained Thunderbird "already running, but is not responding" message

Hello, I’m running a live boot setup with Lubuntu 24.04. In prior versions, I could get into Thunderbird just fine. Now, however, immediately after I start Thunderbird and select my profile, I get this error message:

Thunderbird is already running, but is not responding. To use Thunderbird, you must first close the existing Thunderbird process, restart your device, or use a different profile.

I still get it even after deleting any LOCK and .parentlock files:

$ find ~/snap/thunderbird -iname lock /home/lubuntu/snap/thunderbird/common/.thunderbird/e3t49vjk.default/.parentlock /home/lubuntu/snap/thunderbird/common/.thunderbird/e3t49vjk.default/lock /home/lubuntu/snap/thunderbird/common/.thunderbird/thunderbird/p0dln6zn.default/.parentlock

and I still get it even after STDOUT of

pgrep thunder

comes up empty, as does filtering htop for “thunder”.

Something that might be related is that, given the live boot setup, I copy over profile information from the hard disk into the RAMdisk like so:

cp -R /media/lubuntu/drive/startup/thunderbird /home/lubuntu/snap/thunderbird/common/.thunderbird

cp /media/lubuntu/drive/startup/lubuntu_thunder/profiles.ini /home/lubuntu/snap/thunderbird/common/.thunderbird/

Since Thunderbird is now snap only, I had to adjust the above two-line copy script to account for the new version wanting the data in snap-related directories. Might be related, might not…

Can anyone help determine the cause of this error message?

from the logs attached to https://bugs.launchpad.net/bugs/2046844 I can see thunderbird is being denied


which is in a different location than is what is usually allowed. This is an overlay system so I am assuming that /media is the lower layer of the overlay. Can you post the mount info related to the overlay?

I have verified but I think the following command should be sufficient.

mount | grep overlay