Unable to start Spotify Snap on OpenSuse Linux

Has anybody else had this issue? Worked fine and then suddenly Spotify won’t start and the error is that GTK+ 2 and 3 versions are mixed which is not allowed. Any ideas? Thanks.

Can you paste the terminal output?

Thanks for offering to help. Below is the output


jerid@localhost:~> spotify &
[1] 9430
jerid@localhost:~> Invalid MIT-MAGIC-COOKIE-1 key
(spotify:9430): Gtk-WARNING **: 19:03:42.019: GTK+ module /snap/spotify/50/usr/lib/x86_64-linux-gnu/gtk-2.0/modules/libunity-gtk-module.so cannot be loaded.
GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported.
Gtk-Message: 19:03:42.034: Failed to load module “unity-gtk-module”
Gtk-Message: 19:03:42.034: Failed to load module “canberra-gtk-module”
Invalid MIT-MAGIC-COOKIE-1 keyUnable to init server: Could not connect: Connection refused

(spotify:9430): Gtk-WARNING **: 19:03:42.114: cannot open display: :0

Just for the record, can you run xhost + and then start spotify again? Does it work?

OK. I feel silly now. I thought, let me try another snap of some kind that used to work and see if it works. So I tried Skype, and sure enough it also failed. Then I installed xhost and ran it to grant all clients permission and up came spotify! I also realized that the errors I shared with you were warnings rather than errors. I did see the can’t open display message but assumed that was because it needed the libraries that it was warning about. Anyway, obviously something changed (most likely an update since I didn’t do anything manually to change anything) has now changed the permissions on the xserver. Thanks very much for the help.

OK. I finally figured out what’s different when it works versus when it doesn’t. I do not need to do xhost + if I am plugged into Ethernet. If I am on the wireless setup, it doesn’t work unless I do xhost +. This is OpenSuse Leap 15.3. I am using Network Manager to configure the Wifi config. Any ideas? Thanks.

Not really. The connection should be made over an abstract socket. There was a problem with AppArmor 3 where the access rules were being incorrectly downgraded and blocked all access to X11 socket, but 15.3 still has apparmor 2.xx. Also I don’t remember ever tinkering with this on my Tumbleweed install.

However, I have found a github issue with similar problem but related to flatpaks: https://github.com/flatpak/flatpak/issues/1821 Does your hostname change when you get an address over DHCP when on wireless?

1 Like

Looks like resetting the hostname seems to resolve the issue. I now don’t need to do anything special. Thanks for sharing the link. It was helpful. I do think something isn’t right and it should be handled seamlessly.