Unable to start snaps after moving home partition

Hello, I recently had to move my home partition to another disk because it was taking up too much space. After moving it none of my snaps are working. I can get them to work by going manually to the folder for example “/snap/opera/106/usr/lib/x86_64-linux-gnu/opera/” and I can open up opera. I can’t open the snap store the same way though. Anyone have any idea what I can do to fix this?

Sorry I should of included this in original post. When trying to start the items in /snap/bin through console I get this message:

snap-confine has elevated permissions and is not confined but should be. Refusing to continue to avoid permission escalation attacks

Anyone know how to fix this? Thanks

Edit* I’ve just tried uninstalling it with apt-remove purge and reinstalling it. I reinstalled it all and reinstalled the snap-store, but it still won’t start.

Which distribution is this?

It looks like there is no apparmor profile for snap-confine, while there should be one. Please make sure that the apparmor.service is started and enabled. You can run systemctl start apparmor.service to start it.

The output of sudo aa-status command should now list a profile (or profiles) for snap-confine. Please attach the output of the command when in doubt.

I am on Debian 10.

apparmor module is loaded.
27 profiles are loaded.
25 profiles are in enforce mode.
2 profiles are in complain mode.
3 processes have profiles defined.
3 processes are in enforce mode.
/usr/sbin/haveged (582)
/usr/bin/bash (6329) snap.opera.hook.configure
/snap/opera/106/gnome-platform/usr/bin/fc-cache (6386) snap.opera.hook.configure
0 processes are in complain mode.
0 processes are unconfined but have a profile defined.

I tried completely removing everything to do with snap and reinstalling. I still can’t even open the snap store.

Can you run the following and post the log?

$ SNAPD_DEBUG=1 SNAP_CONFINE_DEBUG=1 snap run <some-snap>

Hey Mborzecki, I managed to get it working. I’m not sure why, but after I installed another program manually using snap install opera, it worked. And so I decided to see if the snap store started working also and to my surprise it did. Not sure how that fixed it or if it was even that, but it seems to be ok now.

Thanks for all your help