Unable to mount


#1

Hello there,

I’m new to snap and want to build an prebuild application, I wrote my own. So I downloaded ubuntu (normally using fedora), installed snapcraft and wrote the following snapcraft.yaml:

    name: audiocuesheeteditor # Name must be lowercase in snap
    base: core18 # the base snap is the execution environment for this snap
    version: '2.4.2'
    summary: Write audio cue sheets fast and efficient
    description: |
      Annoyed of writing your audio cue sheets via text editor? Here comes the solution! Audio Cuesheet Editor helps you editing your audio cuesheet file.

    grade: devel # must be 'stable' to release into candidate/stable channels
    confinement: devmode # use 'strict' once you have the right plugs and slots

    parts:
      audiocuesheeteditor:
        plugin: dump
        source: http://downloads.sourceforge.net/audiocuesheet/AudioCuesheetEditor-linux-x64-v$SNAPCRAFT_PROJECT_VERSION.zip
        
    apps:
      audiocuesheeteditor:
        command: AudioCuesheetEditor

I get the following output, when trying to build the snap:

sven@sven-virtual-machine:~/Downloads$ snapcraft
Launching a VM.
mount failed: Error enabling mount support in 'snapcraft-audiocuesheeteditor'   
An error occurred when trying to mount using 'multipass': returned exit code 2. 

Does anybody have an idea, why this fails? I’m running a VM behind a proxy, which has cost me some time to configure (using PX to gateway the proxy from host to the VM).


#2

Hi @svenB,

So it’s failing enabling mount support, which is essentially the step in Multipass that installs sshfs inside the instance. Since you said you are behind a proxy, I think you may need to tell Multipass about the proxy. You can do this by doing the following:

$ snap set multipass proxy.http=xxx.xxx.xxx.xxx
$ snap set multipass proxy.https=xxx.xxx.xxx.xxx

where xxx.xxx.xxx.xxx is the IP address of your proxy.

Hopefully this helps.

Thanks,
Chris


#3

Thanks for your help. I already set the proxy by the commands you mentioned, so that is currently not helping. Is there any more ideas? Can I find some logs, where the problem can be found?


#4

@svenB,

Ok…are you able to shell into the instance via multipass shell snapcraft-audiocuesheeteditor? If so, you can try to do this:

$ sudo apt update
$ sudo apt install sshfs

This should hopefully tell us what the issue is.


#5

As i’m seeing the same problems with “multipass”, here are some infos from my machine:

After logging into the multipass instance:

Failed to connect to https://changelogs.ubuntu.com/meta-release-lts. Check your Internet connection or proxy settings

“apt update” does not work because it can’t connect to any server:

Err:1 http://archive.ubuntu.com/ubuntu bionic InRelease                                                                    
  Cannot initiate the connection to archive.ubuntu.com:80 (2001:67c:1360:8001::17). - connect (101: Network is unreachable) Cannot initiate the connection to archive.ubuntu.com:80 (2001:67c:1560:8001::11). - connect (101: Network is unreachable) Cannot initiate the connection to archive.ubuntu.com:80 (2001:67c:1360:8001::21). - connect (101: Network is unreachable) Cannot initiate the connection to archive.ubuntu.com:80 (2001:67c:1560:8001::14). - connect (101: Network is unreachable) Could not connect to archive.ubuntu.com:80 (91.189.88.161), connection timed out Could not connect to archive.ubuntu.com:80 (91.189.88.149), connection timed out Could not connect to archive.ubuntu.com:80 (91.189.88.152), connection timed out Could not connect to archive.ubuntu.com:80 (91.189.88.162), connection timed out

I don’t use any proxy servers.


#6

Hi @glasen77 ,

It looks like it’s trying to connect using IPv6. Is your host set up for IPv6 only? We don’t support IPv6 yet in Multipass, so I wonder if this is the problem.


#7

No. I’m also using IPV4. But after trying it today it works again. Strange thing. I didn’t change i thing on my system.


#8

@townsend
Sorry for the late answer, I’ve been a bit busy. I’m currently not able to run the multipass instance even on shell:

sven@sven-virtual-machine:~$ multipass shell snapcraft-audiocuesheeteditor
Welcome to Ubuntu 18.04.2 LTS (GNU/Linux 4.15.0-1030-kvm x86_64)

 * Documentation:  https://help.ubuntu.com
 * Management:     https://landscape.canonical.com
 * Support:        https://ubuntu.com/advantage


  Get cloud support with Ubuntu Advantage Cloud Guest:
    http://www.ubuntu.com/business/services/cloud
This system has been minimized by removing packages and content that are
not required on a system that users do not log into.

To restore this content, you can run the 'unminimize' command.

0 packages can be updated.
0 updates are security updates.

Failed to connect to https://changelogs.ubuntu.com/meta-release-lts. Check your Internet connection or proxy settings

Is there some possibility to tell multipass the proxy in some config file? I browse on the VM, set up apt and firefox to use the proxy and so it seems to me, the system doesn’t recognize the proxy.


#9

Hi @svenB,

Yes you can set the proxy inside the instances via cloud-init. multipass launch accepts a filename after --cloud-init or on standard input if the filename is -.

Also, if you’re using the snap, you can snap set multipass proxy.http=<your proxy>, same for https.