Unable to install Snap Store, nor Discord

To install the Snap Store on Debian I must:

sudo apt update
sudo apt install snapd
sudo snap install core

Install Snap Store

To install Snap Store, simply use the following command:

sudo snap install snap-store

My system is up to date, freshly installed, and also upgraded.
I installed snapd.
I’m unable to install package “core” because E: Unable to locate package core.
How can I install package core to be able to install the Snap Store?

Linux debian 4.19.0-17-amd64 #1 SMP Debian 4.19.194-1 (2021-06-10) x86_64 GNU/Linux

In troubleshooting and trying to install Discord which was my main focus anyway, I came across this:

$ sudo snap install discord
error: cannot communicate with server: Post http://localhost/v2/snaps/discord: dial unix /run/snapd.socket: connect: no such file or directory

Snapd service didn’t start after installation. I had to run

systemctl start snapd.service

then tried to install Discord. It failed with:

sudo snap install discord
error: cannot perform the following tasks:
- Mount snap "discord" (128) (snap "discord" assumes unsupported features: snapd2.43 (try to update snapd and refresh the core snap))

To update/refresh snap:

sudo snap refresh
$ sudo snap refresh
All snaps up to date.

Restarting snapd service didn’t resolve the problem.

I searched online for answers but I couldn’t find any. I give up. I’m just going to install Discord the normal way, through their own deb package. I don’t think I’ll continue using Snap. I was able to install another application through snap but, it seems too buggy to use regularly.

I’m leaving this post up for others who experience similar issues.

try sudo snap install snapd

$ sudo snap install snapd
[sudo] password for user: 
error: cannot install "snapd": cannot install snapd snap on a model without a base snap yet

okay, so try installing the core20 snap first …

$ sudo snap install core20
core20 20210429 from Canonical✓ installed
$ sudo snap install snapd
error: cannot install "snapd": cannot install snapd snap on a model without a base snap yet

what does snap version report ?

$ snap version
snap    2.37.4-1+b1
snapd   2.37.4-1+b1
series  16
debian  10
kernel  4.19.0-17-amd64

hmm, that looks all fine and you say sudo snap install core did return an error (this is weird, given you could install core20) ?

I’m not sure what happened but this is new:

$ sudo snap install core
[sudo] password for user: 
2021-07-11T09:41:23-07:00 INFO Waiting for restart...
core 16-2.51.1 from Canonical✓ installed
Channel latest/stable for core is closed; temporarily forwarding to stable.

this looks fine, try snap version again and see what the snapd version is now …

$ snap version
snap    2.51.1
snapd   2.51.1
series  16
debian  10
kernel  4.19.0-17-amd64

The snap version is different than the previous. Here’s the full recap of what I did that was successful:

$ sudo apt-get install snapd
$ sudo apt upgrade
$ systemctl start snapd.service
$ sudo apt update
$ sudo snap refresh
$ systemctl restart snapd.service
$ sudo snap refresh
All snaps up to date.
$ sudo apt-get install -y libgconf-2-4
$ sudo apt --fix-broken install
$ sudo snap install core20
$ sudo snap install core //core is closed; temporarily forwarding to stable
$ sudo snap install snap-store //supposedly it's installed but it's not showing in Cinnamon menu.

the order should have been:

(though snapd should automatically start after install, i am not sure why you needed to manually start it)

if cinnamon respects the XDG standard it should show up in the menus, note though that extending the menu search paths only happens at login, if you freshly installed snapd you need to log out once (or reboot) to make the change take effect …

1 Like

I’m new to using Cinnamon. Thank you for the suggestion.

I logged out and back in, it still doesn’t appear in the menu. I searched for snap and nothing appeared. If it installed somewhere, it’s not linking to the menu. I don’t know if it can be opened by terminal, but “snap-store” wasn’t found when I tried.

$snap run snap-store
:white_check_mark: