Unable to get snapcraft up and running


I have been following the tutorial here (https://docs.snapcraft.io/build-snaps/get-started-snapcraft)
to get started with snapcraft as I want to snap my python app. I’m using:
ubuntu 16.04.3(LTS) as the base in a vm (VMWare player)

while trying to snapcraft cleanbuild (after following all the steps as specified in the tutorial) I encounter the following error:

Looking up assertion ['account-key', 'public-key-sha3-384=BWDEoaqyr25nF5SNCvEv2v7QnM9QsfCc0PBMYD_i2NGSQ32EF2d4D0hqUel3m8ul']
Looking up assertion ['snap-declaration', 'snap-name=core']
Looking up assertion ['snap-revision', 'snap-revision=4327', 'snap-id=99T7MUlRhtI3U0QFgl5mXXESAiSwt776']
Adding assertion core_4327.assert
Installing /run/core_4327.snap
error: cannot perform the following tasks:
- Mount snap "core" (4327) ([start snap-core-4327.mount] failed with exit status 1: Job for snap-core-4327.mount failed. See "systemctl status snap-core-4327.mount" and "journalctl -xe" for details.
Stopping local:snapcraft-moltenly-untaut-branden
The following command failed to run: 'snap install /run/core_4327.snap' exited with 1

Please, help?


Can you please run this command and paste the output below?

systemctl status snap-core-4327.mount
1 Like

@zyga-snapd here:

kartik@ubuntu:~/test-snapcraft$ systemctl status snap-core-4327.mount
● snap-core-4327.mount - Mount unit for core
   Loaded: loaded (/etc/systemd/system/snap-core-4327.mount; enabled; vendor pre
   Active: active (mounted) since Wed 2018-04-04 01:23:39 PDT; 46min ago
    Where: /snap/core/4327
     What: /dev/loop1
  Process: 395 ExecMount=/bin/mount /var/lib/snapd/snaps/core_4327.snap /snap/co
    Tasks: 0 (limit: 512)

Apr 04 01:23:38 ubuntu systemd[1]: Mounting Mount unit for core...
Apr 04 01:23:39 ubuntu systemd[1]: Mounted Mount unit for core.
lines 1-10/10 (END)

Ah, I think this was inside one of the containers that snapcraft ran. @kalikiana can you confirm this?

tbh I think snap-core is faliling to mount inside the
test container. this paragraph being the suspect

If everything has been configured correctly the sample project will be compressed and a new 
ephemeral LXD container will be created. The compressed project will be copied into the container, 
and snapcraft will run there to create the snap. 
When the process completes, the snap will be pulled from the container, and the container destroyed.

@zyga-snapd I should note that I’d tried this before using Ubuntu 14.04 LTS - I got a touch farther (Can not run snapcraft prime because of pip) and I’d marked that as solved because I thought it might be the host version causing problems.

If somebody finds a solution to this, please @mention me. I’ve just about given up.

I have the same problem,

ERROR: unknown command “download”
this is the problem I think, is there a way to run the plugin code from a local dir ?

the version on pypi.

    # --dest: Download packages into the directory we've set aside for it.
    self._run(['download', '--disable-pip-version-check', '--dest',
               self._python_package_dir] + args, cwd=cwd)