Unable to connect wayland interface to snap for Ubuntu Core

Hi. I am trying to run mir-kiosk-apps on my Ubuntu core. I have successfully connected with the Core pc and installer mir-kiosk-apps, using

snap install mir-kiosk-apps --edge

when I try to start the snap, I get the following error

hiransarkar@ubuntu:~$ mir-kiosk-apps
WARNING: wayland interface not connected! Please run: /snap/mir-kiosk-apps/current/bin/setup.sh
waiting for Wayland socket...
Setting up watches.
Watches established.

I tried to connect the wayland interface to the snap, but no luck

snap connect mir-kiosk-apps:wayland

I get the following error

hiransarkar@ubuntu:~$ snap connect mir-kiosk-apps:wayland
error: snap "snapd" has no "wayland" interface slots

Any help would be really appreciated. Thanks in advance

Do you have a snap that provides the wayland slot installed? For example:

snap install mir-kiosk
snap connect mir-kiosk-apps:wayland mir-kiosk:wayland

Thanks for replying. Unfortunately no, I don’t have any other snap installed on it, but I can install mir-kiosk and send you the console outputs. Give me sometime…

@alan_g. it worked! I can see the snap running on my Ubuntu core. Thanks