Ubuntu ssh connection error

Hi Guys,

I am having Ubuntu 16.04 LTS System and Ubuntu core on Raspberry pi 3 B, When I am try to connect the Ubuntu core by ssh,
it’s shows error (Permission denied (publickey,password).).
I already added the id_rsa.pub key to the SSO login as per the instruction.
I also connect the ubuntu core by Linux system, its connected perfectly.

Please anyone help me to sove this…

You need to specify the username to connect - it is your launchpad username. For example, on launchpad I am diddledan so I connect to my Ubuntu Core device with:

ssh diddledan@pi.example.com

@lucyllewy, Thanks for your reply.

Yeah, I know that… You see I connected the core by Linux System. I recently installed the Ubuntu 16.04 LTS on my System. Now when I connect to the core, it’s asking the password. I don’t know what is the problem here?.. Please anyone guide me to solve this problem… I also tried to change the rsa key multiple times, but nothing worked…

do you have the correct secret part of the key on your desktop machine ?

@ogra, @lucyllewy Thanks for you response guys…
I solved this by deleting the known_host file in the .ssh folder on Ubuntu core.