Ubuntu 18.04 and snap issues


#1

Hello everyone,

I have recently upgraded to 18.04 Ubuntu and I have found some issues with my snaps.

First one Kiosc Editor while it works the way it is meant to work, the icon of the application at the favourites dock is missing

.

Second, I am trying to download our other app Kiosc but it doesn’t appear in the store app, and when I try to do it through the terminal I get the following error:

Why are this issues happening?


#2

This is usually a transient condition on the store. Try again later and it’ll probably work.


#3

Hello Daniel,

I am still not able to find it after 5 days.


#4

workaround for the 401 error, “snap logout” and then “snap login”
maybe…


#5

snap install kiosc
error: cannot perform the following tasks:

  • Download snap “kiosc” (18) from channel “stable” (please buy kiosc before installing it.)

oh… there are payed snaps? o_O
had no idea. cool


#6

Hello pixel,

Yes there are paid snaps !!!:smiley:

But it seams to be working for you, so that is good.

Any idea why the icon issue though?


#7

@cmichael the way the GNOME shell ties icons to windows is different to the way other environments do. If you enable dev tools in gnome, and run the looking glass thing, you’ll see that Kiosc Editor does not have an ‘app’.

I don’t know how to solve this, but I’m sure somebody does :slight_smile:


#8

Thanks to @popey for this:

Rename your desktop file to kiosceditor.desktop and things should work. Tried locally on my 18.04 box and it did the trick (snapd will install it as kiosceditor_kiosceditor.desktop, but gnome shell pics that up without issue).