Trying to snap Lutris, not sure where to go from here


I’m trying to snap Lutris the game manager.

When I run snapcraft I get this error:

The linker version ‘2.23’ used by the base ‘core’ is incompatible with files in this snap:

When I run snapcraft cleanbuild it just sends the error report to the dev team and I’m not sure what the problem is.

Any help on where to go from here would be appreciated, thank you.

Here is my .yaml

Here is the error when running snapcraft

Here is the error when running snapcraft cleanbuild

You’re running snapcraft on bionic (18.04) but building a snap based on xenial (16.04).

I’d recommend adding base: core18 near the top of your yaml and then run snapcraft. You should install multipass snap to build in. This will build based on 18.04 (core 18) and will get you past this error.

Onwards to more interesting errors later. This is a gtk3 app so you’ll need a gtk3 launcher for one.

1 Like

Thanks, adding base: core18 and installing multipass leaves me with this:

$ snapcraft
Launching a VM.
Sorry, an error occurred in Snapcraft.
Sending an error report because ALWAYS was selected in a past prompt.

I’m having trouble finding any error reports. Are they logged to my pc or just sent and deleted?